Bug 183476 - krb5-auth-dialog eats almost 100%
krb5-auth-dialog eats almost 100%
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5-auth-dialog (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 07:16 EST by Radek Vokal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 07:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vokal 2006-03-01 07:16:30 EST
Description of problem:

After `yum update` (1 March 2006) and gnome restart krb5-auth-dialog eats almost
100%

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 2497 rvokal    15   0 33196 9688 8076 S   96  0.9   9:32.63 krb5-auth-dialo

the dialog usually appeared right after gnome start, now it seems to be locked
somewhere.

# gdb -p 2497
(gdb) bt
#0  0x00a6a402 in ?? ()
#1  0x00d3e9dc in poll () from /lib/libc.so.6
#2  0x0772c363 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0x0772c6d9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0x0717f744 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5  0x08049e88 in main (argc=1, argv=Cannot access memory at address 0xb
) at krb5-auth-dialog.c:622
#6  0x00c957a4 in __libc_start_main () from /lib/libc.so.6
#7  0x080496d1 in _start ()
(gdb) info threads
  2 Thread -1211303008 (LWP 2518)  0x00a6a402 in ?? ()
  1 Thread -1209203024 (LWP 2497)  0x00a6a402 in ?? ()
(gdb) thread 2
[Switching to thread 2 (Thread -1211303008 (LWP 2518))]#0  0x00a6a402 in ?? ()
(gdb) bt
#0  0x00a6a402 in ?? ()
#1  0x00d390cb in __write_nocancel () from /lib/libc.so.6
#2  0x00cde11b in _IO_new_file_write () from /lib/libc.so.6
#3  0x00cdde45 in new_do_write () from /lib/libc.so.6
#4  0x00cde0a7 in _IO_new_file_xsputn () from /lib/libc.so.6
#5  0x00cbe45f in buffered_vfprintf () from /lib/libc.so.6
#6  0x00cba348 in vfprintf () from /lib/libc.so.6
#7  0x00d5b58a in __fprintf_chk () from /lib/libc.so.6
#8  0x00b8d6bc in libnm_glib_init () from /usr/lib/libnm_glib.so.0
#9  0x00b8d7cb in libnm_glib_init () from /usr/lib/libnm_glib.so.0
#10 0x077276e1 in g_list_remove_link () from /usr/lib/libglib-2.0.so.0
#11 0x0772909d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0x0772c32f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#13 0x0772c6d9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0x00b8d924 in libnm_glib_init () from /usr/lib/libnm_glib.so.0
#15 0x077468ef in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
#16 0x00288276 in start_thread () from /lib/libpthread.so.0
#17 0x00d4806e in clone () from /lib/libc.so.6


Something more I can provide?

Version-Release number of selected component (if applicable):
krb5-auth-dialog-0.6.cvs20060212-1.i386

How reproducible:
always

Steps to Reproduce:
1. restart gnome with krb5 configured
2.
3.
  
Actual results:
no dialog, deadloop

Expected results:
dialog window

Additional info:
# getenforce
Disabled
Comment 1 Radek Vokal 2006-03-06 07:03:52 EST
Seems to be fine after today rawhide update, closing. 

Note You need to log in before you can comment on or make changes to this bug.