Bug 183479 - missing build requires
missing build requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 07:37 EST by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 07:56:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2006-03-01 07:37:16 EST
Description of problem: 
Trying to build mesa in a minimal  system,  the build failed  due to missing 
headers  
 
Version-Release number of selected component (if applicable): 
mesa-6.4.2-5mesa-6.4.2-5 
 
How reproducible: 
always 
 
Steps to Reproduce: 
1.rpmbuild -ba mesa.spec 
2. 
3. 
   
Actual results: 
 
gcc -c -I../../include -I/usr/include/Motif1.2 -I/usr/contrib/X11R6/include 
-I/usr/X11R6/include -Wall -O -g -fPIC  -D_POSIX_SOURCE 
-D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE 
-DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING 
-DHAVE_ALIAS  -std=c99 -ffast-math  GLwDrawA.c 
GLwDrawA.c:48:28: X11/IntrinsicP.h: No such file or directory 
GLwDrawA.c:49:28: X11/StringDefs.h: No such file or directory 
In file included from GLwDrawAP.h:46, 
                 from GLwDrawA.c:56: 
gcc -c -I../../include -I/usr/include/Motif1.2 -I/usr/contrib/X11R6/include 
-I/usr/X11R6/include -Wall -O -g -fPIC  -D_POSIX_SOURCE 
-D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE 
-DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING 
-DHAVE_ALIAS  -std=c99 -ffast-math  GLwDrawA.c 
GLwDrawA.c:48:28: X11/IntrinsicP.h: No such file or directory 
GLwDrawA.c:49:28: X11/StringDefs.h: No such file or directory 
In file included from GLwDrawAP.h:46, 
                 from GLwDrawA.c:56: 
 
Expected results: 
 
builds ok 
 
Additional info: 
 
missing dep is libXt-devel
Comment 1 Karsten Hopp 2006-03-01 07:56:48 EST
mesa-6.4.2-6 

Note You need to log in before you can comment on or make changes to this bug.