Bug 183540 - foomatic unable to match usb device epson photo stylus 825
foomatic unable to match usb device epson photo stylus 825
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 16:07 EST by Jeff MacDonald
Modified: 2015-01-20 14:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 12:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Epson-Stylus_Photo_825.xml (1.25 KB, text/plain)
2006-03-02 07:44 EST, Tim Waugh
no flags Details

  None (edit)
Description Jeff MacDonald 2006-03-01 16:07:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
I used the system-config-print utility to print a number of test pages. all worked fine. because I started the utility from a terminal, however, the following message was printed:

No match for USB device:
  mfr "EPSON"
  model "Stylus Photo 825"
  desc "EPSON Stylus Photo 825"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Version-Release number of selected component (if applicable):
foomatic-3.0.2-19.2

How reproducible:
Didn't try

Steps to Reproduce:
1. run system-config-printer from terminal
2.
3.
  

Actual Results:  the program does not crash and seems to be operating correctly, however the message said to report this issue in bugzilla.


Additional info:
Comment 1 Tim Waugh 2006-03-02 07:44:10 EST
Created attachment 125528 [details]
Epson-Stylus_Photo_825.xml

Please save this attachment and copy it to:

  /usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_825.xml

When you go to add a new queue for the printer, is the correct model
automatically selected from the list now?
Comment 2 Jeff MacDonald 2006-03-02 13:19:34 EST
no. the list comes up and the manuf. is "generic".. I then need to go and pick
exactly what I want from the list.

the list of devices is correctly showing the printer manuf. and model number,
however.
Comment 3 Tim Waugh 2006-03-03 03:58:49 EST
Hmm.

1. On the 'Queue type' screen, does the line you click on say 'EPSON Stylus
Photo 825'?
2. Also, do you get the same "No match" message as before when you click 'Forward'?
3. Lastly, what does 'rpm -q foomatic' say?
Comment 4 Jeff MacDonald 2006-03-03 15:14:36 EST
1. yes. the device is /dev/usb/lp0 and right next to it is has the correct
manuf./model number.
2. yes. when I get to the next screen where I need to pick the manufacturer and
model, the drop box says "generic" instead of "epson", and when I check the
terminal window that I ran system-config-printer from, I get the same output as
before.
3. foomatic-3.0.2-19.2

Comment 5 Tim Waugh 2006-12-12 12:40:48 EST
Pretty sure this is fixed now.
Comment 6 Fedora Update System 2015-01-20 14:10:57 EST
libyui-3.1.5-1.fc21,libyui-bindings-1.1.0-1.fc21,libyui-gtk-2.44.5-5.fc21,libyui-ncurses-2.46.7-1.fc21,libyui-qt-2.46.13-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libyui-3.1.5-1.fc21,libyui-bindings-1.1.0-1.fc21,libyui-gtk-2.44.5-5.fc21,libyui-ncurses-2.46.7-1.fc21,libyui-qt-2.46.13-1.fc21
Comment 7 Fedora Update System 2015-01-20 14:11:16 EST
libyui-3.1.5-1.el7,libyui-bindings-1.1.0-1.el7,libyui-gtk-2.44.5-5.el7,libyui-ncurses-2.46.7-1.el7,libyui-qt-2.46.13-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/libyui-3.1.5-1.el7,libyui-bindings-1.1.0-1.el7,libyui-gtk-2.44.5-5.el7,libyui-ncurses-2.46.7-1.el7,libyui-qt-2.46.13-1.el7

Note You need to log in before you can comment on or make changes to this bug.