Bug 183574 - net-snmp-devel 5.2.1 fails
net-snmp-devel 5.2.1 fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
: 183575 183576 183577 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 20:46 EST by david_suffield
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 10:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david_suffield 2006-03-01 20:46:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
After trying to build/run HPLIP, I discovered that the snmp packages for FC3 through yum are broken. Here are the failing packages.

net-snmp 5.2.1
net-snmp-devel 5.2.1

The original FC3 snmp packages work ok.

net-snmp 5.1.2
net-snmp-devel 5.1.2

I had to go back to the original FC3 cd to get the correct snmp packages.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. After installing net-snmp-devel with yum, the symlinks in /usr/lib were bogus. 

2. After manually fixing the symlinks and re-compiling HPLIP with net-snmp-devel 5.2.1, all network HPLIP I/O fails (ie: Hp-makeuri).

  

Additional info:
Comment 1 Frank Arnold 2006-03-02 02:09:59 EST
*** Bug 183575 has been marked as a duplicate of this bug. ***
Comment 2 Frank Arnold 2006-03-02 02:10:33 EST
*** Bug 183576 has been marked as a duplicate of this bug. ***
Comment 3 Frank Arnold 2006-03-02 02:11:26 EST
*** Bug 183577 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vokal 2006-03-02 02:19:04 EST
What exactly fails? net-snmp of hplip? Do you have strace of the crash? Or you
just don't see the values queried by snmpget? The reproduce steps are not very
clear to me.
Comment 5 david_suffield 2006-03-02 12:45:40 EST
Fix the symlink problem in step 1 and I will recheck hplip in step 2. After
installing net-snmp-devel from yum the following symlinks are invalid.

/usr/lib/libnetsnmp.so
/usr/lib/libnetsnmpagent.so
/usr/lib/libnetsnmphelpers.so
/usr/lib/libnetsnmpmibs.so
/usr/lib/libnetsnmptrapd.so
Comment 6 Radek Vokal 2006-03-09 06:52:50 EST
Ok, on my FC4 laptop, net-snmp untouched installing net-snmp-devel went fine.
And the symlinks are ok.

# ll /usr/lib/libnetsnmp*
-rw-r--r--  1 root root 902988 Jul 13  2005 /usr/lib/libnetsnmp.a
-rw-r--r--  1 root root 344652 Jul 13  2005 /usr/lib/libnetsnmpagent.a
-rwxr-xr-x  1 root root    765 Jul 13  2005 /usr/lib/libnetsnmpagent.la
lrwxrwxrwx  1 root root     24 Mar  9 12:53 /usr/lib/libnetsnmpagent.so ->
libnetsnmpagent.so.5.2.1
lrwxrwxrwx  1 root root     24 Mar  9 12:52 /usr/lib/libnetsnmpagent.so.5 ->
libnetsnmpagent.so.5.2.1
-rwxr-xr-x  1 root root 232312 Jul 13  2005 /usr/lib/libnetsnmpagent.so.5.2.1
-rw-r--r--  1 root root 183062 Jul 13  2005 /usr/lib/libnetsnmphelpers.a
-rwxr-xr-x  1 root root    779 Jul 13  2005 /usr/lib/libnetsnmphelpers.la
lrwxrwxrwx  1 root root     26 Mar  9 12:53 /usr/lib/libnetsnmphelpers.so ->
libnetsnmphelpers.so.5.2.1
lrwxrwxrwx  1 root root     26 Mar  9 12:52 /usr/lib/libnetsnmphelpers.so.5 ->
libnetsnmphelpers.so.5.2.1
-rwxr-xr-x  1 root root 110328 Jul 13  2005 /usr/lib/libnetsnmphelpers.so.5.2.1
-rwxr-xr-x  1 root root    730 Jul 13  2005 /usr/lib/libnetsnmp.la
-rw-r--r--  1 root root 792668 Jul 13  2005 /usr/lib/libnetsnmpmibs.a
-rwxr-xr-x  1 root root    758 Jul 13  2005 /usr/lib/libnetsnmpmibs.la
lrwxrwxrwx  1 root root     23 Mar  9 12:53 /usr/lib/libnetsnmpmibs.so ->
libnetsnmpmibs.so.5.2.1
lrwxrwxrwx  1 root root     23 Mar  9 12:52 /usr/lib/libnetsnmpmibs.so.5 ->
libnetsnmpmibs.so.5.2.1
-rwxr-xr-x  1 root root 467424 Jul 13  2005 /usr/lib/libnetsnmpmibs.so.5.2.1
lrwxrwxrwx  1 root root     19 Mar  9 12:53 /usr/lib/libnetsnmp.so ->
libnetsnmp.so.5.2.1
lrwxrwxrwx  1 root root     19 Mar  9 12:52 /usr/lib/libnetsnmp.so.5 ->
libnetsnmp.so.5.2.1
-rwxr-xr-x  1 root root 582468 Jul 13  2005 /usr/lib/libnetsnmp.so.5.2.1
-rw-r--r--  1 root root  66118 Jul 13  2005 /usr/lib/libnetsnmptrapd.a
-rwxr-xr-x  1 root root    765 Jul 13  2005 /usr/lib/libnetsnmptrapd.la
lrwxrwxrwx  1 root root     24 Mar  9 12:53 /usr/lib/libnetsnmptrapd.so ->
libnetsnmptrapd.so.5.2.1
lrwxrwxrwx  1 root root     24 Mar  9 12:52 /usr/lib/libnetsnmptrapd.so.5 ->
libnetsnmptrapd.so.5.2.1
-rwxr-xr-x  1 root root  49272 Jul 13  2005 /usr/lib/libnetsnmptrapd.so.5.2.1

 I don't have any FC-3 machine around right now. I'd recommed rebuilding
net-snmp package from srpm as well as hplip against new net-snmp.

Note You need to log in before you can comment on or make changes to this bug.