Bug 183581 - Network scripts invalidate hotplug... problem for Prism54
Network scripts invalidate hotplug... problem for Prism54
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-03-01 22:07 EST by Nathanael Noblet
Modified: 2008-01-19 23:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-19 23:36:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathanael Noblet 2006-03-01 22:07:14 EST
+++ This bug was initially created as a clone of Bug #113462 +++

I'm not sure that this is the same problem, however whenever I boot up, the
prism54 interface requires a rmmod prism54, modprobe prism54 and service network
restart to successfully work. This card has been working flawlessly for 9 months
in a debian based system previously.
Comment 1 Bill Nottingham 2006-03-02 00:38:25 EST
This sounds like a driver bug - assgining there.
Comment 2 Nathanael Noblet 2006-03-02 05:18:42 EST
Come to think of it, it very well could be. I have been experiencing odd
connectivity issues, however it seemed at the time to be solely http related.
When I first installed FC5-test3. I couldn't download certain files. Sounds
completely hokey I know, however I tried downloading flash for linux likely 20
times in 2 days with no success. Used a different machine to download it, then
scp no problem to this machine (through the wireless card no less) ? Again later
in the day, trying to install a package through pear, it couldn't finish the
download of symfony (1.2M) it would die at various dowload stages. I couldn't
download the tar.gz manually with firefox or wget, however, downloading it to
another machine and scp'ing it again worked. The very weird thing is, I did a
base install with next to nothing a few days ago, and have used yum to install
whole package groups, development, games, office productivity. LOTS of
downloading, nothing failed... Can't explain it. I'm a fairly proficient
programmer though never done anything in the kernel so what can I do to help?
Comment 3 Nathanael Noblet 2006-03-06 13:13:27 EST
Just a thought as I go through the /var/log/boot file. Is the prism54 module
loaded from initrd? If that is the case then it would explain the
non-functioning driver as it requires a firmware upload. However the filesystems
aren't mounted until much later, which have the firmware and the hotplug scripts
to load it.
Comment 4 Dave Jones 2006-10-16 13:21:20 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Jon Stanley 2008-01-19 23:36:39 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.