Bug 183600 - Add glx-utils (glxgears/glxinfo) package to default GUI install
Add glx-utils (glxgears/glxinfo) package to default GUI install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 02:58 EST by David Timms
Modified: 2013-01-09 20:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 13:12:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against comps.xml FC5T3 (nearby spacing as well). (954 bytes, patch)
2006-03-02 02:58 EST, David Timms
no flags Details | Diff

  None (edit)
Description David Timms 2006-03-02 02:58:45 EST
Description of problem:
There is no simple way to test open GL included in FC5T3.

Version-Release number of selected component (if applicable):
FC5T3 + devel updates @ 2006-03-02

How reproducible:
All possibly.

Steps to Reproduce:
1. Install FC5T3 with GUI environment
2. try to run glxinfo or glxgears to test GL operation
  
Actual results:
Neither are installed by default.

Expected results:
glxinfo and glxgears should be available by default after installing the "base
graphical (X) user interface"  (but run from the command line).

Additional info:
1. With the change to modular X
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=173510 , glxgears/info
weren't being packages, but are now in a separate package glx-utils, that isn't
in the GUI package selections.
2. workaround- yum install glx-utils
3. as briefly discussed on fedora-test-list.
4. # rpm -q --requires glx-utils libGL.so.1
libGLU.so.1
libX11.so.6
libc.so.6
libc.so.6(GLIBC_2.0)
libglut.so.3
libm.so.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
5. # rpm -qf libGL.so.1 libGLU.so.1 libX11.so.6 libglut.so.3
mesa-libGL-6.4.2-5
mesa-libGLU-6.4.2-5
libX11-1.0.0-3
freeglut-2.4.0-4
6 # rpm -qf libc.so.6 libm.so.6
glibc-2.3.90-38
glibc-2.3.90-38
Comment 1 David Timms 2006-03-02 02:58:45 EST
Created attachment 125517 [details]
patch against comps.xml FC5T3 (nearby spacing as well).
Comment 2 Warren Togami 2006-03-02 13:12:23 EST
Looks like somebody already did this.

Note You need to log in before you can comment on or make changes to this bug.