Bug 183628 - dos2unix delete files.
dos2unix delete files.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: dos2unix (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On: 123069
Blocks: 143573
  Show dependency treegraph
 
Reported: 2006-03-02 07:30 EST by Tim Waugh
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-145
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 15:52:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-03-02 07:30:00 EST
+++ This bug was initially created as a clone of Bug #123069 +++

Description of problem:
dos2unix filas when cuurent directory is on a different file system
than the 
output file.  If output and input file is the same file, the input
file is 
furthermore deleted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /home/user
2. touch /tmp/foo
3. dos2unix /tmp/foo
	

Actual Results:  If /home/usr and /tmp are on different file systems,
/tmp/foo is permanently deleted.

Expected Results:  it to work

Additional info:
(from another user)
The cause is trivial, input file is `unlink'ed, output generated as a
temporary file in the current directory and the tried `rename'd to the
output location.  `rename' obviously fails, as it cannot move between
file systems.

-- Additional comment from bugzilla@dsmouse.net on 2004-05-12 13:08 EST --
Created an attachment (id=100195)
patch to fix problem


-- Additional comment from mharris@redhat.com on 2004-10-06 16:14 EST --
*** Bug 134361 has been marked as a duplicate of this bug. ***

-- Additional comment from mitr@redhat.com on 2004-10-20 11:31 EST --
Fixed in dos2unix-3.1-21. Thanks for your report.

-- Additional comment from timp@redhat.com on 2005-05-19 20:35 EST --

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html
Comment 4 Red Hat Bugzilla 2006-03-13 15:52:11 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-145.html

Note You need to log in before you can comment on or make changes to this bug.