Bug 183652 - udev-0.84-10 cd/dvd scheme is a mess
udev-0.84-10 cd/dvd scheme is a mess
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 10:14 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 07:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2006-03-02 10:14:58 EST
I actually got your 0.84-10 version and installed. This was supposed to
create a cdrom link but it did not!

Furthermore, the new scheme is a mess. I have a cdrw and dvdrw devices and
here is what I had before and after (you be the judge):

udev-0.84-6

lrwxrwxrwx 1 root root 3 Mar  2 09:10 dvd -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 09:10 dvdwriter -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 09:10 cdrom -> hda
lrwxrwxrwx 1 root root 3 Mar  2 09:10 cdwriter -> hda
udev-0.84-10

lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvd -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvd-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvdrw -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvdrw-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvdwriter -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 dvdwriter-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 cdrw -> hdb
lrwxrwxrwx 1 root root 3 Mar  2 08:57 cdrw-hda -> hda
lrwxrwxrwx 1 root root 3 Mar  2 08:57 cdrw-hdb -> hdb
Comment 1 Harald Hoyer 2006-03-02 10:46:00 EST
which kernel do you use?
Comment 2 Sammy 2006-03-02 10:49:29 EST
I am using 2.6.15.3 based kernel, everything else is at daily rawhide level.
Comment 3 Harald Hoyer 2006-03-02 10:55:54 EST
you should have with kernel-2.6.15-1.1975_FC5:
$ cat /sys/block/hda/device/media 
cdrom
$ cat /sys/block/hdb/device/media 
cdrom
Comment 4 Sammy 2006-03-02 11:35:57 EST
Hi, I have the kernel 2.6.15-1.1826.2.14_FC5 which is 2.10 recompiled with
2.6.15.4 patch. For this kernel there is no media in /sys but in /proc :

cat /proc/ide/ide0/hda/media
cdrom
cat /proc/ide/ide0/hdb/media
cdrom

I don't have 1.1975 but I guess you are telling me that I some point kernel
moved these to /sys interface. If you need me to try out let me know.
Comment 5 Sammy 2006-03-02 15:42:20 EST
Using 2.6.15-1.1996_FC5 from rawhide I have:

IN /sys:

cat /sys/devices/pci0000:00/0000:00:1f.1/ide0/0.1/media
cdrom
cat /sys/devices/pci0000:00/0000:00:1f.1/ide0/0.0/media
cdrom

AND in /proc

cat /proc/ide/ide0/hda/media
cdrom
cat /proc/ide/ide0/hdb/media
cdrom


Comment 6 Harald Hoyer 2006-03-03 00:08:05 EST
and for 2.6.15-1.1996_FC5 you should then have /dev/cdrom...
Comment 7 Sammy 2006-03-03 11:57:01 EST
So, there sould be a kernel requires for latest udev's? It seems like it
because I have another problem with older kernels and udev-0.84-10, namely
SCSI tape logical link is not created with -10 but created with -6. I have
an external scsi tape nst0.

The only reason I am using the old kernel is due to sound problems with
intel-hda on the 2.6.16 based kernels. As soon as kernel people fix this
I will update (I hope they will for 2.6.16 final).
Comment 8 Sammy 2006-03-09 09:53:44 EST
Again, a recap with a 2.6.15.6 based kernel and udev-0.84-13:

The system has a CDRW as hda and a DVD/RW as hdb, as well as an external scsi
tape drive nst0. Missing logical links are cdrom and tape. Also, I think 
cdwriter should point to hda while dvdwriter correctly points to hdb. Here is
what I have:

lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdrw -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdrw-hda -> hda
lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdrw-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdwriter -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdwriter-hda -> hda
lrwxrwxrwx 1 root root 3 Mar  9 08:46 cdwriter-hdb -> hdb

lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvd -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvd-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvdrw -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvdrw-hdb -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvdwriter -> hdb
lrwxrwxrwx 1 root root 3 Mar  9 08:46 dvdwriter-hdb -> hdb
Comment 9 Harald Hoyer 2006-03-09 10:00:52 EST
please use a Fedora kernel or patch the Fedora kernel...
Comment 10 Sammy 2006-03-09 12:06:38 EST
I am using the latest FC4 kernel update recompiled on FC5. What
would be the patch? I can deal with this by putting logical links
into /etc/udev/devices but I was wondering if the latest udev
requires a Fedora kernel greater than certain version.

I'll switch to 2.6.16 base when alsa people solve the hda-intel
sound (or no sound) problem, which is not making it into the final
2.6.16 because the changes are too big.

Note You need to log in before you can comment on or make changes to this bug.