Bug 183700 - No i586, i686 support in Extras buildsys
No i586, i686 support in Extras buildsys
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 16:49 EST by Ville Skyttä
Modified: 2014-01-21 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 00:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-03-02 16:49:25 EST
I submitted a kernel module test build but got quick bad results:

http://buildsys.fedoraproject.org/build-status/job.psp?uid=5745
Package thinkpad-kmod-5_9-2_2_6_15_1_1996_FC5 does not build on any
architectures this build system supports.
Package: ['i586', 'i686']
Build System: ['i386', 'x86_64', 'ppc']
Comment 1 Ville Skyttä 2006-03-08 12:42:04 EST
Dan, others, any info about this one?  Should building for i586 and i686 be
supported in the FE buildsys?
Comment 2 Dan Williams 2006-03-11 17:08:36 EST
It's not currently supported for anything, but it definitely will be supported
for kmod building.
Comment 3 Dan Williams 2006-03-13 00:33:25 EST
Ok, plague 0.4.4 and CVS HEAD have the necessary fixes for kmod support.  You'll
still have to manually bump the kernel version that the package depends on for
the time being, but when I update the buildsys tomorrow you should be able to
push your package through for any arches you want on FC3, FC4, and devel.
Comment 4 Dan Williams 2006-03-13 14:01:51 EST
Can you try now?  Buildsys is updated, so the package should make it through.
Comment 5 Ville Skyttä 2006-03-13 16:29:17 EST
Looks good, thanks:

http://buildsys.fedoraproject.org/build-status/job.psp?uid=6288
http://buildsys.fedoraproject.org/build-status/job.psp?uid=6292

While preparing the lirc-kmod test build, I noticed that the ppc repo carries
also ppc64 and ppc64iseries kernels, and we'll probably want to build modules
for them too.  Judging from the builder listing at
http://buildsys.fedoraproject.org/build-status/builders.psp I guess there are no
builders available for them at the moment though.  Also, a quick peek to the
buildsys sources tells me that ppc64iseries config bits seem to be missing.  Is
that correct, or should I just try ppc64 and/or ppc64iseries builds too with
lirc-kmod?
Comment 6 Dan Williams 2006-03-13 16:42:15 EST
There's no ppc64iseries support yet, and I don't know what that would involve. 
I think it's just a matter of adding the correct config magic and things should
just work.  But it's not supported right yet.
Comment 7 Ville Skyttä 2006-03-14 02:24:07 EST
Ok, opened bug 185387 for that.

Note You need to log in before you can comment on or make changes to this bug.