Bug 18372 - Number Nine i128v2 XF86_I128 fails after upgrade 6.2 -> 7.0
Number Nine i128v2 XF86_I128 fails after upgrade 6.2 -> 7.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 22:21 EDT by mmoneta
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-11 18:41:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mmoneta 2000-10-04 22:21:45 EDT
With a working X configuration for a Number Nine i128 series 2 video card
on Redhat 6.2, upgrade to 7.0 via boxed set.  X fails to start after the
upgrade reporting the error "I128: ibm528 Ramdac not found.".  Backing out
X to the previously used version allows X to be used under 7.0.

XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF] 
Configured drivers:
  I128: server for I128 graphics adaptors (Patchlevel 0)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: ps/2, device: /dev/mouse, buttons: 3
(**) I128: Graphics device ID: "Imagine 128v2"
(**) I128: Monitor ID: "Hitachi CM801"
(--) I128: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) I128: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) I128: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) I128: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(**) FontPath set to "unix/:-1"
(--) I128: I128-II revision (2)
(--) I128: card type: PCI
(**) I128: videoram:  8192k
I128: ibm528 Ramdac not found.

 *** A configured device found, but display modes could not be resolved.***


Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

X connection to :0.0 broken (explicit kill or server shutdown).
Comment 1 Scott Dowdle 2000-10-25 00:03:09 EDT
I experienced this problem when installing on a friends machine.  We didn't try reverting back to the 6.2 server.  My friend ended up reinstalling Mandrake. :(  Now that I know there is a work around, all is not lost. :)
Comment 2 Dave Petro 2000-10-29 13:20:54 EST
Ditto on my system. I upgraded to version 7.0 via the boxed set from a 6.1 base 
with numerous package upgrades. No more X with my Number Nine I128.
Comment 3 Darin Adler 2000-11-30 18:35:00 EST
I had the same problem, and found a Debian bug report that mentions this issue. 
According to that bug report (which can be found at 
<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=45157>), the problem comes from 
compiling XFree86 with egcs -- a code generation issue of some kind that results in a 
server that does not properly set the clock.

Downgrading the XFree86-I128 package to the version that came with Red Hat 6.2 
(XFree86-I128-3.3.6-20.i386.rpm) solved the problem for me.
Comment 4 Mike A. Harris 2001-03-10 01:20:17 EST
Can you try the latest package in rawhide and let me know if it works for you?
The i128 driver has had many fixes since you've experienced this problem.

ftp://people.redhat.com/mharris/xfree86
Comment 5 mmoneta 2001-03-10 08:28:05 EST
I upgraded to the rawhide XFree86-I128-3.3.6-35, and XFree86-4.0.2-11 
packages.  The I128 driver works great!  Initially, X restarted every few 
minutes, but that appears to be some problem with XFree86-XFS-4.0.2.11 (no 
error messages).  Since I changed the XF86Config and XF86Config-4 to not use 
XFS, the system has been perfectly stable.
Comment 6 mmoneta 2001-03-10 09:17:52 EST
I upgraded to the XFree86-4.0.2-12.1 packages you pointed to as well.  So far so
good with XFS too.
Comment 7 mmoneta 2001-03-11 18:41:26 EST
XFS died again, so I stopped using it.  The I128 driver has been perfect.
Comment 8 Mike A. Harris 2001-03-23 04:05:24 EST
Great, I'm glad the i128 works for you now.  The xfs crash problems
should all be fixed now in our XFree86-4.0.3 release also.

Note You need to log in before you can comment on or make changes to this bug.