Bug 183733 - IPW2200 and kernel-2.6.15-1.1996_FC5 failing
IPW2200 and kernel-2.6.15-1.1996_FC5 failing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 02:21 EST by Clayton Rogers
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 10:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Rogers 2006-03-03 02:21:56 EST
Description of problem:
I have the ipw2200 firmware installed for my Intel Corporation PRO/Wireless
2915ABG MiniPCI Adapter.  I receive the following error when activating the
wireless device:
NETDEV_TX_BUSY returned; driver should report queue full via
ieee_device->is_queue_full.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1996_FC5

How reproducible:
All the time

Steps to Reproduce:
1.rmmod ipw2200 at boot
2.modprobe ipw2200 
3.produces NETDEV_TX_BUSY returned; driver should report queue full via
ieee_device->is_queue_full. in /var/log/messages
  
Actual results:
NETDEV_TX_BUSY returned; driver should report queue full via
ieee_device->is_queue_full.

Expected results:
Start activating the network device in NetworkManager and acquiring a network
address.

Additional info:
Apparently supposed to have been fixed in version 1.0.9 of the ipw2200 module.
Comment 1 Bastien Nocera 2006-04-22 17:51:07 EDT
Seeing this with an ipw2200 adapter on a 2.6.16-1.2069_FC5 kernel.
Comment 2 John W. Linville 2006-05-18 15:35:08 EDT
Is this issue still occurring w/ current Fedora kernels
Comment 3 Horst H. von Brand 2006-05-18 17:48:11 EDT
Not here anymore, for quite some time.
Comment 4 John W. Linville 2006-05-19 10:14:46 EDT
Horst, are you on FC5?  Or rawhide? 
 
It looks like this is (mostly) fixed upstream, but the fix is not in FC5. 
Comment 5 Horst H. von Brand 2006-05-19 10:37:44 EDT
Sorry, didn't notice this is Fedora 5. I'm on rawhide, and here ipw2200 works
just fine for quite some time now.
Comment 6 Clayton Rogers 2006-05-19 16:55:48 EDT
It is still occurring on my end on a stock standard FC5.  Details below: 
# uname -a
Linux zion 2.6.16-1.2111_FC5 #1 Thu May 4 21:16:58 EDT 2006 i686 i686 i386 GNU/Linux
rmmod ipw2200
modprobe ipw2200
eth0: NETDEV_TX_BUSY returned; driver should report queue full via
ieee_device->is_queue_full.
Comment 7 John W. Linville 2006-05-21 16:16:00 EDT
Clayton, thanks for the confirmation.  Please see comment 4. 
Comment 8 Behdad Esfahbod 2006-08-15 00:15:52 EDT
Suffering this in an updated FC5 everyday...  Any hope to have it fixed?
Comment 9 John W. Linville 2006-08-15 09:18:33 EDT
Behdad, please include the output of 'uname -r'?  The patch for this issue 
seems to be in the latest FC5 kernels already.

Note You need to log in before you can comment on or make changes to this bug.