Bug 18381 - Blackdown Java incompatible with compat-glibc
Summary: Blackdown Java incompatible with compat-glibc
Status: CLOSED DUPLICATE of bug 18049
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-05 06:36 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 06:36:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-05 06:36:20 UTC
The compat-glibc does not provide compatibility with Blackdown Java JDK.
I'm primarily using B/D JDK 118v1 but have also tried 1.2.2.

Similar problems were reported against earlier version of Blackdown which
required the updating of glibc versions. Since RedHat 7 is meant to be
providing the compatible versions of glibc I feel this is now relevant to
RedHat _as_well_as_ Blackdown

[root@smallbottom /root]# javac
SIGSEGV   11*  segmentation violation
        stackbase=(nil), stackpointer=(nil)

Full thread dump:
    NULL (TID:0x403dd0b0, sys_thread_t:0x80eea18, state:R) prio=5 *current
thread*
        java.lang.System.nullInputStream(System.java)
        java.lang.System.<clinit>(System.java)
        java.lang.String.getChars(String.java)
        java.lang.StringBuffer.append(StringBuffer.java)
        java.lang.StringBuffer.<init>(StringBuffer.java)
        java.lang.Thread.<init>(Thread.java)
Monitor Cache Dump:
    java.lang.Class@1077792856/1079893136: owner NULL (0x80eea18, 1 entry)
    java.lang.StringBuffer@1077793128/1079893024: owner NULL (0x80eea18, 1
entry)
Registered Monitor Dump:
    Thread queue lock: <unowned>
    Name and type hash table lock: <unowned>
    String intern lock: <unowned>
    JNI pinning lock: <unowned>
    JNI global reference lock: <unowned>
    BinClass lock: <unowned>
    Class loading lock: <unowned>
    Java stack lock: <unowned>
    Code rewrite lock: <unowned>
    Heap lock: <unowned>
    Has finalization queue lock: <unowned>
    Finalize me queue lock: <unowned>
    Dynamic loading lock: owner NULL (0x80eea18, 1 entry)
    Monitor IO lock: <unowned>
    Child death monitor: <unowned>
    Event monitor: <unowned>
    I/O monitor: <unowned>
    Alarm monitor: <unowned>
    Monitor registry: owner NULL (0x80eea18, 1 entry)
Thread Alarm Q:
/usr/local/java/jdk/bin/i686/green_threads/javac: line 13:  1699
Aborted                 (core dumped) `dirname $0`/${progname}
$RUNTIME_ARGS -ms8m $RUNTIME_ARGS sun.tools.javac.Main $APP_ARGS

[root@smallbottom /root]# java -version
java version "1.1.8"

[root@smallbottom /root]# ldconfig -V
ldconfig (GNU libc) 2.1.92
Copyright (C) 2000 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Andreas Jaeger.

Comment 1 Jakub Jelinek 2000-10-05 10:08:41 UTC

*** This bug has been marked as a duplicate of 18049 ***


Note You need to log in before you can comment on or make changes to this bug.