Bug 183872 - Questionable packages in "build"-groups
Summary: Questionable packages in "build"-groups
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Jeremy Katz
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-03 10:28 UTC by Ralf Corsepius
Modified: 2007-04-18 17:39 UTC (History)
2 users (show)

Fixed In Version: N/A
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-20 12:02:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2006-03-03 10:28:51 UTC
Description of problem:

The default buildroots.xml files as being used by mock
http://fedoraproject.org/buildgroups/*/*/buildroots.xml
contain several packages of doubtful usefulness for a buildsystem.

In particular:
* gdb
* strace 
* indent

I can hardly imagine situations where these will be applied when building
packages. Even if they should be needed by something, I hardly can imagine
reasons why these packages couldn't handle these deps by explicit
"BuildRequires" and why these would justify pulling them into a default buildroot.

Comment 1 Till Maas 2006-09-02 20:56:10 UTC
It seems to be that these packages have been removed from the default buildroot,
so I guess this can be closed.

Comment 2 Ralf Corsepius 2007-02-20 12:02:19 UTC
(In reply to comment #1)
> It seems to be that these packages have been removed from the default buildroot,
> so I guess this can be closed.

Yes - Wondering why the bug owner didn't ...


Note You need to log in before you can comment on or make changes to this bug.