Bug 183874 - OpenSSH closes connection on linux_audit_write_entry failure
Summary: OpenSSH closes connection on linux_audit_write_entry failure
Status: CLOSED DUPLICATE of bug 183243
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-03 10:46 UTC by Lubomir Bulej
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 11:01:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Custom kernel configuration (41.62 KB, text/plain)
2006-03-03 10:46 UTC, Lubomir Bulej
no flags Details

Description Lubomir Bulej 2006-03-03 10:46:45 UTC
Description of problem:

OpenSSH server closes connections on linux_audit_write_entry_failure, 
thus preventing interactive login to a remote machine. Execution of commands on
remote machine is not affacted, i.e. still works. I suspect this is caused by my
custom configured kernel which does not support selinux and auditing.

Version-Release number of selected component (if applicable):
custom kernel 2.6.15-1.1977_FC5 (without selinux and auditing)
custom kernel-smp 2.6.15-1.1991_FC5 (without selinux and auditing)
openssh-4.3p2-3

How reproducible:
Always.

Steps to Reproduce:
1. install kernel without selinux
2. install openssh-4.3p2-3
3. try to log on the machine using ssh
  
Actual results:
[pallas@irian ~]$ ssh localhost
Connection to localhost closed by remote host.
Connection to localhost closed.

Expected results:
Login shell on the remote machine.

Additional info:
/var/log/secure contains the following:

Mar  3 10:50:19 irian sshd[13168]: Postponed publickey for pallas from 127.0.0.1
port 41766 ssh2
Mar  3 11:50:19 irian sshd[13165]: Accepted publickey for pallas from 127.0.0.1
port 41766 ssh2
Mar  3 10:50:19 irian sshd[13168]: Accepted publickey for pallas from 127.0.0.1
port 41766 ssh2
Mar  3 11:50:19 irian sshd[13177]: pam_unix(sshd:session): session opened for
user pallas by (uid=0)
Mar  3 11:50:19 irian sshd[13177]: pam_loginuid(sshd:session): set_loginuid
failed opening loginuid
Mar  3 11:50:19 irian sshd[13165]: fatal: linux_audit_write_entry failed:
Connection refused
Mar  3 11:50:19 irian sshd[13165]: syslogin_perform_logout: logout() returned an
error
Mar  3 11:50:19 irian sshd[13177]: pam_unix(sshd:session): session closed for
user pallas

Comment 1 Lubomir Bulej 2006-03-03 10:46:45 UTC
Created attachment 125588 [details]
Custom kernel configuration

Comment 2 Tomas Mraz 2006-03-03 11:01:46 UTC

*** This bug has been marked as a duplicate of 183243 ***


Note You need to log in before you can comment on or make changes to this bug.