Bug 183885 - vconfig.x86_64 have i386 binaries
vconfig.x86_64 have i386 binaries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vconfig (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 08:08 EST by kloczek
Modified: 2015-03-04 20:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 08:32:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kloczek 2006-03-03 08:08:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060212 Epiphany/1.9

Description of problem:
I have system with only x86_64/noarch packages. After last upgrade I found in installed packages list glibc.i686. But ..

# rpm -e glibc.i686
error: Failed dependencies:
        libc.so.6 is needed by (installed) vconfig-1.9-1.1.x86_64
        libc.so.6(GLIBC_2.0) is needed by (installed) vconfig-1.9-1.1.x86_64

This is because dist source tar ball have macvlan_config and vconfig i386 binaries and 'make CCFLAGS="%{optflags}"' does nothing and in %install are installed binaries from dist tar ball.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
# file /sbin/vconfig
/sbin/vconfig: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped
# uname -a
Linux boss 2.6.15-1.1996_FC5 #1 SMP Tue Feb 28 16:04:41 EST 2006 x86_64 x86_64 x86_64 GNU/Linux


Additional info:
Comment 1 Phil Knirsch 2006-03-03 08:32:09 EST
This has been fixed in the latest vconfig build.

Package should appear in rawhide in the next few days.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.