Bug 183893 - autofs logs errors to syslog when using LDAP
autofs logs errors to syslog when using LDAP
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 09:31 EST by Henning Schmiedehausen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: autofs-4.1.4-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-02 22:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Schmiedehausen 2006-03-03 09:31:38 EST
Description of problem:

The problem described in debian bug #315465 at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=315465 also applies to the
Autofs version of Fedora Core 4. It is still present in RawHide!


Version-Release number of selected component (if applicable):

autofs-4.1.4-15.1 (Fedora Core 4)
autofs-4.1.4-16.2.2 (Rawhide)


How reproducible:

Always. Just look at the syslog:

Mar  3 15:31:55 srva035 automount[2397]: lookup(ldap): got answer, but no first
entry for (&(objectclass=nisObject)(cn=henning))
Mar  3 15:31:55 srva035 automount[2397]: lookup(ldap): got answer, but no first
entry for (&(objectclass=automount)(cn=henning))

Steps to Reproduce:
1. set up autofs to use ldap. We use

/sbin/service autofs status
Configured Mount Points:
------------------------
ldap1.,ldap2:nisMapName=auto.home,ou=mounts,o=domain
hard,intr,lock,v3,rsize=8192,wsize=8192

2.

List out a directory through autofs: I can use "ls /home/henning"

3.

Look into the syslog
  
Actual results:

Error messages are displayed.

Expected results:

No errors should be displayed.

Additional info:

Same as debian bug #315465, they solved by upgrading to 4.1.5
Comment 1 Jeffrey Moyer 2006-03-03 09:35:57 EST
Interesting fix, since there is no 4.1.5.  Anyway, we have a fix in the RHEL
repositories for this.  Ian, you want to take care of this?

-Jeff
Comment 2 Henning Schmiedehausen 2006-03-03 11:46:13 EST
Yep, it is 4.1.4-5. Sorry, I was sloppy. Thanks for looking into this.
Comment 3 Roozbeh Pournader 2006-06-21 08:41:36 EDT
The recent update to autofs (autofs-4.1.4-26) says that it fixes this bug.
Should the bug be closed?
Comment 4 Ian Kent 2006-06-21 10:45:46 EDT
(In reply to comment #3)
> The recent update to autofs (autofs-4.1.4-26) says that it fixes this bug.
> Should the bug be closed?

Yep. I'll get to it.
As I said previously I like to leave calls open in case of
unexpected problems.

Ian
Comment 5 Ian Kent 2006-06-21 21:26:06 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > The recent update to autofs (autofs-4.1.4-26) says that it fixes this bug.
> > Should the bug be closed?
> 

This slipped through but I believe it is now fixed.
Can you test the latest FC-5 update and verify please.


Note You need to log in before you can comment on or make changes to this bug.