Bug 183959 - dmraid incorrectly processes command line
dmraid incorrectly processes command line
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
:
: 187962 187963 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 21:42 EST by Roman Ekjanov
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-12 05:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Ekjanov 2006-03-03 21:42:20 EST
dmraid fails to activate a RAID set with error:
ERROR: No arguments allowed with -i

dmraid-1.0.0.rc9-FC5_5.2


How reproducible:
This is how dmraid is invoked in rc.sysinit:
/sbin/dmraid -ay --ignorelocking nvidia_ffbcacae

Actual results:
ERROR: No arguments allowed with -i

Expected results:
silently activate the set

looks like that dmraid thinks that the RAID set name is an argument to
--ignorelocking option.
Comment 1 Heinz Mauelshagen 2006-03-21 04:45:13 EST
Fixed
Comment 2 Heinz Mauelshagen 2006-04-05 06:04:43 EDT
*** Bug 187962 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2006-04-26 12:22:08 EDT
*** Bug 187963 has been marked as a duplicate of this bug. ***
Comment 4 Michal Jaegermann 2006-05-12 18:43:39 EDT
Comment #1 says "Fixed" but the bug is still present in FC5 as of
2006-05-12.
Comment 5 Milan Broz 2006-07-12 05:02:25 EDT
Already fixed in dmraid-1.0.0.rc11-FC6 in devel branch.

Note You need to log in before you can comment on or make changes to this bug.