Bug 183970 - javax.swing.plaf.basic.BasicHTML missing
javax.swing.plaf.basic.BasicHTML missing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 05:34 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-18 18:08:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2006-03-04 05:34:11 EST
Description of problem:
I'm attempting to build Limewire (possibly for FE) using gcj and have all of the
ant components and gcj rpms installed (including all -devel rpms). The core will
build, but the GUI comes up with the error

The import of javax.swing.plaf.basic,BasicHTML cannot be resolved

Version-Release number of selected component (if applicable):
classpathx-mail-monolithic-1.0-4jpp_4fc
classpathx-jaf-1.0-2jpp_4fc
classpathx-jaf-javadoc-1.0-2jpp_4fc
classpathx-mail-1.0-4jpp_4fc
classpathx-mail-javadoc-1.0-4jpp_4fc
libgcj-4.1.0-1
libgcj-devel-4.1.0-1
libgcj-4.1.0-1
ant-1.6.5-1jpp_6fc
ant-trax-1.6.5-1jpp_6fc
ant-antlr-1.6.5-1jpp_6fc
ant-junit-1.6.5-1jpp_6fc
ant-javadoc-1.6.5-1jpp_6fc
ant-jsch-1.6.5-1jpp_6fc
ant-nodeps-1.6.5-1jpp_6fc
ant-commons-logging-1.6.5-1jpp_6fc
ant-apache-resolver-1.6.5-1jpp_6fc
ant-apache-log4j-1.6.5-1jpp_6fc
ant-javamail-1.6.5-1jpp_6fc
ant-debuginfo-1.6.5-1jpp_6fc
ant-manual-1.6.5-1jpp_6fc
ant-scripts-1.6.5-1jpp_6fc
ant-apache-regexp-1.6.5-1jpp_6fc
ant-swing-1.6.5-1jpp_6fc
ant-apache-oro-1.6.5-1jpp_6fc
ant-apache-bsf-1.6.5-1jpp_6fc
ant-apache-bcel-1.6.5-1jpp_6fc
ant-jdepend-1.6.5-1jpp_6fc
gcc-java-4.1.0-1

How reproducible:
Always

Steps to Reproduce:
1. Grab the source for limewire, cd trunk/gui
2. ant
3.
  
Actual results:
Build fails as javax.swing.plaf.basic.BasicHTML cannot be resolved

Expected results:
Build should work

Additional info:
This is the first java app I've every attempted to make, so it's equally
possibly that I'm at fault. Build not attempted on x86 box only x86_64
Comment 1 Thomas Fitzsimmons 2006-03-04 18:43:16 EST
This class is missing from Rawhide libgcj but it is present in GNU Classpath
HEAD.  Rawhide libgcj ships with an old import of GNU Classpath for stability. 
I'm working on back-porting Swing and AWT from a more current Classpath release
to FC5's libgcj.  If the merge is successful then
javax.swing.plaf.basic.BasicHTML will be imported and limewire will be (closer
to?) buildable.

If you're really keen on making limewire build on the free stack you could try
building it against GNU Classpath HEAD (I'd be very interested to know the
results).  Setting up a NativeEclipse-based GNU Classpath development
environment is trivial now, see our Wiki page:

http://developer.classpath.org/mediation/ClasspathHackingWithEclipse
Comment 2 Paul F. Johnson 2006-03-04 18:52:50 EST
I've built and tested the core, so I know that's happy with the gcj stack (I'm
yet to find any real stability issues - see below). However, because of the
BasicHTML being missing, I can't test the GUI part.

The stability issues.

I can't get it to crash as the testing really doesn't amount to much or to being
anything getting close to extensive. I guess I'll know more when the class is
imported or I test using the link above.
Comment 3 Paul F. Johnson 2006-03-18 18:08:33 EST
I'll close this for now and marked it as upstream (not actually sure if this can
be considered as a bug as it doesn't actually exist as such!)

Note You need to log in before you can comment on or make changes to this bug.