Bug 183973 - Hard Link count wrong for /selinux
Hard Link count wrong for /selinux
Status: CLOSED DUPLICATE of bug 182001
Product: Fedora
Classification: Fedora
Component: findutils (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 06:40 EST by Adam Bowns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 11:01:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Bowns 2006-03-04 06:40:08 EST
Description of problem:

As root, if I do	find / -iname test.txt
I get the following error: -

find: WARNING: Hard link count is wrong for /selinux: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.

An:			ls -l /selinux
gives the following: -

total 0
-rw-rw-rw- 1 root root    0 Mar  4 11:06 access
dr-xr-xr-x 2 root root    0 Mar  4 11:06 avc
dr-xr-xr-x 2 root root    0 Mar  4 11:06 booleans
-rw-r--r-- 1 root root    0 Mar  4 11:06 checkreqprot
--w------- 1 root root    0 Mar  4 11:06 commit_pending_bools
-rw-rw-rw- 1 root root    0 Mar  4 11:06 context
-rw-rw-rw- 1 root root    0 Mar  4 11:06 create
--w------- 1 root root    0 Mar  4 11:06 disable
-rw-r--r-- 1 root root    0 Mar  4 11:06 enforce
-rw------- 1 root root    0 Mar  4 11:06 load
-rw-rw-rw- 1 root root    0 Mar  4 11:06 member
-r--r--r-- 1 root root    0 Mar  4 11:06 mls
crw-rw-rw- 1 root root 1, 3 Mar  4 11:06 null
-r--r--r-- 1 root root    0 Mar  4 11:06 policyvers
-rw-rw-rw- 1 root root    0 Mar  4 11:06 relabel
-rw-rw-rw- 1 root root    0 Mar  4 11:06 user

Note, the “null” is highlighted in black.

Version-Release number of selected component (if applicable):
libselinux-devel-1.29.7-1.2
selinux-policy-2.2.21-7
libselinux-1.29.7-1.2
libselinux-python-1.29.7-1.2
selinux-policy-targeted-2.2.21-7
kernel-2.6.15-1.2009.4.2_FC5

How reproducible:
Everytime I do a find as root.

Steps to Reproduce:
1. As root do: find / -iname test
  
Actual results:
The above error.

Expected results:
No error.

Additional info:
I'm running FC5 Test 3 kept up to date with the development tree on VMWare
workstation 5.5.1
Comment 1 Miloslav Trmač 2006-03-04 11:01:02 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.



*** This bug has been marked as a duplicate of 182001 ***

Note You need to log in before you can comment on or make changes to this bug.