Bug 183992 - smbd hangs on directory listing of an autofs mountpoint when the automount map is stored in LDAP
smbd hangs on directory listing of an autofs mountpoint when the automount ma...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 13:06 EST by Rik Theys
Modified: 2010-05-11 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 08:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik Theys 2006-03-04 13:06:03 EST
Description of problem:

We have a /software directory under which we mount other directories using
autofs. The auto.software map is stored in LDAP.

When a client opens the \\samba-server\software share (is a share for
/software), the connection dies after a while. smbclient gives the
following error:

Call timed out: server did not respond after 20000 milliseconds listing \*
Error in dskattr: Call timed out: server did not respond after 20000 milliseconds

When we configure autofs to use NIS as the source for the map, the results are 
OK: we see the currently mounted directories.

How reproducible:

Always


Steps to Reproduce:
1. Configure autofs to use a map stored in LDAP
2. From a client perform a: smbclient //server/autofs-mountpoint-share and
   do an 'ls'
3.
  
Actual results:

After a while, smbclient returns:

Call timed out: server did not respond after 20000 milliseconds listing \*
Error in dskattr: Call timed out: server did not respond after 20000 milliseconds

Other commands following this message (for ex. 'cd map-entry1') immediately
returns the same error.

Expected results:

Directory listing showing the currently mounted subdirectories


Additional info:

We've configured samba as a member server in a Windows domain.
We don't have a default entry in the LDAP map.

Our /var/log/messages shows the following entries:
Mar  4 17:48:55 congo automount[16031]: lookup(ldap): query failed for (&(object
class=nisObject)(cn=automount(pid7910)))                                       
Mar  4 17:48:55 congo automount[16031]: lookup(ldap): query failed for
(&(objectclass=automount)(cn=automount(pid7910)))
Mar  4 17:48:55 congo automount[16031]: lookup(ldap): query failed for
(&(objectclass=automount)(automountKey=automount(pid7910)))                    
         Mar  4 17:48:55 congo automount[16031]: failed to mount
/software/automount(pid7910)
Comment 1 Dmitri Pal 2010-05-10 10:35:04 EDT
This is not a Samba issue.
Comment 2 Ian Kent 2010-05-10 22:37:24 EDT
This looks like it's four years old?

Is this still a problem?
Comment 3 Rik Theys 2010-05-11 02:30:35 EDT
Yes the bug was filed four years ago. It's no longer a problem. You can close this call...
Comment 4 Ian Kent 2010-05-11 08:29:55 EDT
(In reply to comment #3)
> Yes the bug was filed four years ago. It's no longer a problem. You can close
> this call...    

OK.

Wow, four years is not good.
If only I had seen this we probably could have sorted it out
much earlier.

Sorry.
Ian

Note You need to log in before you can comment on or make changes to this bug.