Bug 18404 - CRC error after install
CRC error after install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 10:06 EDT by aia21
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 20:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aia21 2000-10-05 10:06:37 EDT
After having installed RH 7.0 (using custom install and install everything
selected) everything seemed to go fine. - The first reboot came and the
lilo graphical screen comes up and works. However, as soon as the kernel
starts to load it halts with a "CRC error".
The computer is a several years old custom built PC with Triton chipset
motherboard, Pentium 120S CPU, 64MB ECC RAM, Adaptec SCSI controller (of
some description - possibly AHA2940), one IBM 4GB SCSI HD and Intel
ethernet card of some description (Ether Pro 10  or so). - Install was
performed via NFS using the netboot.img on a floppy.
Let me know if you need more info.
Comment 1 Michael Fulbright 2000-10-05 17:49:05 EDT
What exactly do you see on the screen after the graphical LILO screen?
Comment 2 aia21 2000-10-05 18:53:29 EDT
I just tried several times to boot and it seems to be doing three things (at 
random one of them and then need to reboot):

1)
--screen output start --
Loading linux.....................
Uncompressing Linux...

crc error

 -- System halted
--screen output end --

2)
--screen output start --
Loading linux.....................
Uncompressing Linux... _
--screen output end --
the _ is the blinking cursor and it hangs like that.

3)
--screen output start --
Loading linux.....................
Uncompressing Linux... <spontaneous reboot without me touching anything!>
Comment 3 Michael Fulbright 2000-10-06 16:36:13 EDT
It appears that your kernel image may be corrupt. I would recommend reinstalling
(save anything you want to keep) and seeing if this helps.
Comment 4 aia21 2000-10-07 19:58:32 EDT
I have now reinstalled 4 times (complete reformat every time) and I even tried 
with/without the linear option but still doesn't work. - Always the same 
result. - Except if linear option is used the displayed text changes to:

Loading linux......................
Uncompressing Linux...

invalid compressed format (err=2)

 -- System halted

[To make sure the hardware is ok I installed Windows 98 and that is working 
absolutely fine.]

Is the kernel version used for the bootnet.img the same as the kernel that is 
installed on disk? - If not, maybe there is a SCSI driver problem with the 
AHA2940 on the installed kernel?

The boot floppy that is created during installation fails to boot in exactly 
the same way as straight off the hard drive.

On the other hand, when booting with the installation floppy (bootnet.img) and 
using the boot command: linux rescue
The system boots fine and I am dropped into a shell from which I am able to 
mount the installation partition (after mknod /dev/sda*...) and can cat files 
from it fine so the data is not corrupted on the disk.

Any suggestions?
Comment 5 aia21 2000-10-08 12:55:08 EDT
To follow up my previous comments:

When booting after the install it still crashes as described above but booting 
using the install disk and doing linux rescue drops me in a shell. - I can then 
mount my installed root partition and the system is fine. - Executables run, 
etc. no problems. - Also, I recompiled the kernel with all my devices compiled 
in and not being modules and ran lilo but booting still crashes in the same way 
as with the original installation kernel!

Very weird indeed. Oh, and there is a new error message I just saw:

Loading Linux................
Uncompressing Linux...

ran out of input data


 -- System halted
Comment 6 aia21 2000-10-16 20:47:00 EDT
This is now solved. - The BIOS required 2 8-bit waitstates to be set and now it 
works fine! - Sorry for the inconvenience caused. - Obviously Linux was/is 
doing something more hardware pushing than windows so windows worked with a 
different waitstate but linux didn't...
Comment 7 5pam Man 2001-08-13 15:32:36 EDT
this wait state you speak of how exactly did you implement this?
I have the same problem it is really fun.
Thanks

Note You need to log in before you can comment on or make changes to this bug.