Bug 18404 - CRC error after install
Summary: CRC error after install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-05 14:06 UTC by aia21
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2000-10-17 00:48:29 UTC


Attachments (Terms of Use)

Description aia21 2000-10-05 14:06:37 UTC
After having installed RH 7.0 (using custom install and install everything
selected) everything seemed to go fine. - The first reboot came and the
lilo graphical screen comes up and works. However, as soon as the kernel
starts to load it halts with a "CRC error".
The computer is a several years old custom built PC with Triton chipset
motherboard, Pentium 120S CPU, 64MB ECC RAM, Adaptec SCSI controller (of
some description - possibly AHA2940), one IBM 4GB SCSI HD and Intel
ethernet card of some description (Ether Pro 10  or so). - Install was
performed via NFS using the netboot.img on a floppy.
Let me know if you need more info.

Comment 1 Michael Fulbright 2000-10-05 21:49:05 UTC
What exactly do you see on the screen after the graphical LILO screen?

Comment 2 aia21 2000-10-05 22:53:29 UTC
I just tried several times to boot and it seems to be doing three things (at 
random one of them and then need to reboot):

1)
--screen output start --
Loading linux.....................
Uncompressing Linux...

crc error

 -- System halted
--screen output end --

2)
--screen output start --
Loading linux.....................
Uncompressing Linux... _
--screen output end --
the _ is the blinking cursor and it hangs like that.

3)
--screen output start --
Loading linux.....................
Uncompressing Linux... <spontaneous reboot without me touching anything!>


Comment 3 Michael Fulbright 2000-10-06 20:36:13 UTC
It appears that your kernel image may be corrupt. I would recommend reinstalling
(save anything you want to keep) and seeing if this helps.

Comment 4 aia21 2000-10-07 23:58:32 UTC
I have now reinstalled 4 times (complete reformat every time) and I even tried 
with/without the linear option but still doesn't work. - Always the same 
result. - Except if linear option is used the displayed text changes to:

Loading linux......................
Uncompressing Linux...

invalid compressed format (err=2)

 -- System halted

[To make sure the hardware is ok I installed Windows 98 and that is working 
absolutely fine.]

Is the kernel version used for the bootnet.img the same as the kernel that is 
installed on disk? - If not, maybe there is a SCSI driver problem with the 
AHA2940 on the installed kernel?

The boot floppy that is created during installation fails to boot in exactly 
the same way as straight off the hard drive.

On the other hand, when booting with the installation floppy (bootnet.img) and 
using the boot command: linux rescue
The system boots fine and I am dropped into a shell from which I am able to 
mount the installation partition (after mknod /dev/sda*...) and can cat files 
from it fine so the data is not corrupted on the disk.

Any suggestions?

Comment 5 aia21 2000-10-08 16:55:08 UTC
To follow up my previous comments:

When booting after the install it still crashes as described above but booting 
using the install disk and doing linux rescue drops me in a shell. - I can then 
mount my installed root partition and the system is fine. - Executables run, 
etc. no problems. - Also, I recompiled the kernel with all my devices compiled 
in and not being modules and ran lilo but booting still crashes in the same way 
as with the original installation kernel!

Very weird indeed. Oh, and there is a new error message I just saw:

Loading Linux................
Uncompressing Linux...

ran out of input data


 -- System halted

Comment 6 aia21 2000-10-17 00:47:00 UTC
This is now solved. - The BIOS required 2 8-bit waitstates to be set and now it 
works fine! - Sorry for the inconvenience caused. - Obviously Linux was/is 
doing something more hardware pushing than windows so windows worked with a 
different waitstate but linux didn't...


Comment 7 5pam Man 2001-08-13 19:32:36 UTC
this wait state you speak of how exactly did you implement this?
I have the same problem it is really fun.
Thanks



Note You need to log in before you can comment on or make changes to this bug.