Bug 184050 - Cannot install slave server onto port 389
Cannot install slave server onto port 389
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 10:43 EST by Graham Leggett
Modified: 2008-08-11 19:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 18:13:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2006-03-05 10:43:52 EST
After successfully installing a standalone directory server, an attempt is made
to install a second directory server with the configuration installed in the
first directory server.

After entering the machine name and port number of the standalone directory
server , the following message is displayed:

 The standard directory server network port number is 389.  However, if
 you are not logged as the superuser, or port 389 is in use, the
 default value will be a random unused port number greater than 1024.
 If you want to use port 389, make sure that you are logged in as the
 superuser, that port 389 is not in use, and that you run the admin
 server as the superuser.


 Directory server network port [42098]:

For no clear reason, setup refuses to allow port 389 to be used:

 ERROR: Unable to bind to port 389
 Please choose another port.

The following conditions are true:

- Setup is being run as the superuser
- Port 389 is not already used (checked with telnet, nmap and fuser)
- No idea what the admin server has to do with anything

Setup can only continue at this point by choosing a port above 1024.

To fix this:

- The screens need to be made clear whether we are talking about *this*
directory server, the *configuration* directory server, and whether we are
choosing the port for the directory server, or the admin server.

- The error message about not being able to connect to port 389 should say *why*
it could not bind to port 389 (address already in used, permission denied,
whatever).
Comment 1 Rich Megginson 2006-03-13 17:38:30 EST
What OS is this?  What version of FDS is this?  Are you using SELinux?
Comment 2 Nathan Kinder 2006-10-31 18:13:26 EST
Closing this bug since we haven't heard back on the issue and we are unable to
reproduce it.  Feel free to reopen the bug if there is a reproducible test.
Comment 3 Chandrasekar Kannan 2008-08-11 19:44:53 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.