Bug 184060 - hard to reproduce segfault
hard to reproduce segfault
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 13:55 EST by Scott Tsai
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-03-05 13:55:43 EST
Description of problem:
Was able to segfault firefox when browsing, cannot reproduce since.
traceback attached.


Version-Release number of selected component (if applicable):
firefox-1.5.0.1-5
gtk2-2.8.13-3
cairo-1.0.2-5


How reproducible:
hard

Steps to Reproduce:
(not quite sure)

Additional info:
Program terminated with signal 11, Segmentation fault.
<...snip...>
#0  0x00002b1a72709e1d in raise () from /lib64/libpthread.so.0
#1  0x00000000004135a3 in nsProfileLock::FatalSignalHandler (signo=11) at
nsProfileLock.cpp:206
#2  <signal handler called>
#3  0x00002b1a7293b72f in cairo_xlib_surface_set_drawable () from
/usr/lib64/libcairo.so.2
#4  0x00002b1a7292610c in cairo_scaled_font_glyph_extents () from
/usr/lib64/libcairo.so.2
#5  0x00002b1a729273c7 in cairo_font_options_create () from /usr/lib64/libcairo.so.2
#6  0x00002b1a7292805f in cairo_font_options_create () from /usr/lib64/libcairo.so.2
#7  0x00002b1a72928513 in cairo_font_options_create () from /usr/lib64/libcairo.so.2
#8  0x00002b1a72922349 in cairo_show_glyphs () from /usr/lib64/libcairo.so.2
#9  0x00000037fa305ece in pango_cairo_show_glyph_string () from
/usr/lib64/libpangocairo-1.0.so.0
#10 0x00000037fbe210c2 in pango_renderer_draw_glyphs () from
/usr/lib64/libpango-1.0.so.0
#11 0x00000037fa305376 in pango_cairo_show_glyph_string () from
/usr/lib64/libpangocairo-1.0.so.0
#12 0x00000037fbe210c2 in pango_renderer_draw_glyphs () from
/usr/lib64/libpango-1.0.so.0
#13 0x00000037fbe2149d in pango_renderer_draw_layout_line () from
/usr/lib64/libpango-1.0.so.0
#14 0x00000037fb12460a in gdk_draw_layout_line_with_colors () from
/usr/lib64/libgdk-x11-2.0.so.0
#15 0x00000037fb124733 in gdk_draw_layout_line () from
/usr/lib64/libgdk-x11-2.0.so.0
#16 0x00002aaaabe06d77 in nsFontMetricsPango::DrawString (this=0x2aaab28e9da0,
    aString=0x2aaab287c5d0 "From Wikibooks, the open-content textbooks
collection", aLength=53, aX=Variable "aX" is not available.
) at nsFontMetricsPango.cpp:721
#17 0x00002aaaabdfcf76 in nsRenderingContextGTK::DrawString (this=Variable
"this" is not available.
) at nsRenderingContextGTK.cpp:1314
#18 0x00002aaaace202f5 in nsTextFrame::PaintAsciiText (this=0x2aaab2886910,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
    aStyleContext=0x2aaab2886878, aTextStyle=@0x7fffff832e90, dx=0, dy=0) at
nsTextFrame.cpp:3603
#19 0x00002aaaace2206f in nsTextFrame::Paint (this=0x2aaab2886910,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0, aDirtyRect=Variable
"aDirtyRect" is not available.
)
    at nsTextFrame.cpp:1611
#20 0x00002aaaacddcd53 in nsContainerFrame::PaintChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:282
#21 0x00002aaaacddd2ba in nsContainerFrame::PaintChildren (this=0x2aaab2886808,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
    aDirtyRect=@0x7fffff833120, aWhichLayer=eFramePaintLayer_Overlay, aFlags=0)
at nsContainerFrame.cpp:227
#22 0x00002aaaacdf08f2 in nsHTMLContainerFrame::PaintDecorationsAndChildren
(this=0x2aaab2886808, aPresContext=0x3336cf0,
    aRenderingContext=@0x2aaab2a2e1a0, aDirtyRect=@0x7fffff833120,
aWhichLayer=eFramePaintLayer_Overlay, aIsBlock=0, aFlags=0)
    at nsHTMLContainerFrame.cpp:136
#23 0x00002aaaacdfa32a in nsInlineFrame::Paint (this=0x2aaab2886808,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
aDirtyRect=@0x7fffff833120,
    aWhichLayer=eFramePaintLayer_Overlay, aFlags=0) at nsInlineFrame.cpp:326
#24 0x00002aaaacddcd53 in nsContainerFrame::PaintChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:282
#25 0x00002aaaacdcf4ed in PaintLine (aLineArea=Variable "aLineArea" is not
available.
) at nsBlockFrame.cpp:6363
#26 0x00002aaaacdd06f0 in nsBlockFrame::PaintChildren (this=0x2aaab28862b8,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
    aDirtyRect=@0x7fffff833380, aWhichLayer=eFramePaintLayer_Overlay,
aFlags=Variable "aFlags" is not available.
) at nsBlockFrame.cpp:6432
#27 0x00002aaaacdf08f2 in nsHTMLContainerFrame::PaintDecorationsAndChildren
(this=0x2aaab28862b8, aPresContext=0x3336cf0,
    aRenderingContext=@0x2aaab2a2e1a0, aDirtyRect=@0x7fffff833380,
aWhichLayer=eFramePaintLayer_Overlay, aIsBlock=1, aFlags=0)
    at nsHTMLContainerFrame.cpp:136
#28 0x00002aaaacdcf71d in nsBlockFrame::Paint (this=0x2aaab28862b8,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
aDirtyRect=@0x7fffff833380,
    aWhichLayer=eFramePaintLayer_Overlay, aFlags=Variable "aFlags" is not available.
) at nsBlockFrame.cpp:6257
#29 0x00002aaaacddcd53 in nsContainerFrame::PaintChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:282
#30 0x00002aaaacdcf4ed in PaintLine (aLineArea=Variable "aLineArea" is not
available.
) at nsBlockFrame.cpp:6363
#31 0x00002aaaacdd06f0 in nsBlockFrame::PaintChildren (this=0x2aaab28397b8,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
    aDirtyRect=@0x7fffff833670, aWhichLayer=eFramePaintLayer_Overlay,
aFlags=Variable "aFlags" is not available.
) at nsBlockFrame.cpp:6432
#32 0x00002aaaacdf08f2 in nsHTMLContainerFrame::PaintDecorationsAndChildren
(this=0x2aaab28397b8, aPresContext=0x3336cf0,
    aRenderingContext=@0x2aaab2a2e1a0, aDirtyRect=@0x7fffff833670,
aWhichLayer=eFramePaintLayer_Overlay, aIsBlock=1, aFlags=0)
    at nsHTMLContainerFrame.cpp:136
#33 0x00002aaaacdcf71d in nsBlockFrame::Paint (this=0x2aaab28397b8,
aPresContext=0x3336cf0, aRenderingContext=@0x2aaab2a2e1a0,
aDirtyRect=@0x7fffff833670,
    aWhichLayer=eFramePaintLayer_Overlay, aFlags=Variable "aFlags" is not available.
) at nsBlockFrame.cpp:6257
#34 0x00002aaaacdbdffc in PresShell::Paint (this=0x4482060, aView=Variable
"aView" is not available.
) at nsPresShell.cpp:5815
#35 0x00002aaaacfdbd59 in nsView::Paint (this=0x2aaab2882c50,
rc=@0x2aaab2a2e1a0, rect=@0x7fffff833670, aPaintFlags=Variable "aPaintFlags" is
not available.
) at nsView.cpp:314
#36 0x00002aaaacfdf0ca in nsViewManager::RenderDisplayListElement (this=Variable
"this" is not available.
) at nsViewManager.cpp:1458
#37 0x00002aaaacfe1ad7 in nsViewManager::RenderViews (this=0x47754b0,
aRootView=Variable "aRootView" is not available.
) at nsViewManager.cpp:1373
---Type <return> to continue, or q <return> to quit---
#38 0x00002aaaacfe4b9d in nsViewManager::Refresh (this=0x47754b0,
aView=0x2aaab2880bb0, aContext=0x2aaab2a2e1a0, aRegion=0x2aaab2ae1cc0,
aUpdateFlags=Variable "aUpdateFlags" is not available.
)
    at nsViewManager.cpp:929
#39 0x00002aaaacfe510c in nsViewManager::DispatchEvent (this=0x47754b0,
aEvent=0x7fffff833b80, aStatus=0x7fffff833b4c) at nsViewManager.cpp:2045
#40 0x00002aaaacfdc520 in HandleEvent (aEvent=0x7fffff833b80) at nsView.cpp:171
#41 0x00002aaaaaf1dc2a in nsCommonWidget::DispatchEvent (this=0x2aaab2ae6350,
aEvent=0x7fffff833b80, aStatus=@0x7fffff833c28) at nsCommonWidget.cpp:219
#42 0x00002aaaaaf18a97 in nsWindow::OnExposeEvent (this=0x2aaab2ae6350,
aWidget=Variable "aWidget" is not available.
) at nsWindow.cpp:1344
#43 0x00002aaaaaf18b2e in expose_event_cb (widget=0x6cd5c0,
event=0x7fffff834350) at nsWindow.cpp:3623
#44 0x00000037fb623c3d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#45 0x00000037f8f0b21d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#46 0x00000037f8f1af28 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#47 0x00000037f8f1c13d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#48 0x00000037f8f1c553 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#49 0x00000037fb6fd49e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#50 0x00000037fb61e9f2 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#51 0x00000037fb13257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#52 0x00000037fb13270b in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#53 0x00000037fb13277a in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#54 0x00000037f8926f7a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#55 0x00000037f892a105 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#56 0x00000037f892a42d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#57 0x00000037fb61ecd3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#58 0x00002aaaaaf1cc3a in nsAppShell::Run (this=0x6d0700) at nsAppShell.cpp:139
#59 0x00002aaaab393488 in nsAppStartup::Run (this=0x6d0680) at nsAppStartup.cpp:150
#60 0x000000000040b23f in XRE_main (argc=Variable "argc" is not available.
) at nsAppRunner.cpp:2313
#61 0x00002b1a72c0a084 in __libc_start_main () from /lib64/libc.so.6
#62 0x0000000000406b29 in _start ()
#63 0x00007fffff834ed8 in ?? ()
#64 0x0000000000000000 in ?? ()
Comment 1 Matěj Cepl 2007-12-20 11:47:45 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.