This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 184066 - 'vbetool post' complains on Thinkpad X41 (Intel 915 Express/82801FB/FBM/FR/FW/FRW)
'vbetool post' complains on Thinkpad X41 (Intel 915 Express/82801FB/FBM/FR/FW...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 15:53 EST by Tom London
Modified: 2015-03-04 20:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 18:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ouput of 'strace vbetool post' (27.08 KB, text/plain)
2006-03-05 15:53 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2006-03-05 15:53:09 EST
Description of problem:
Running 'vbetool post' on my Thinkpad X41 produces the following:
Calling INT 0x15 (F000:654B)
 EAX is 0x5F20
Error: something went wrong performing real mode call

I'm running latest Rawhide, pm-utils-0.13-1, kernel-2.6.15-1.2009.4.2_FC5 with
SELinux in permissive mode.

I ran 'strace -o vbetool.strace /usr/sbin/vbetool post', and I attach the output.

Version-Release number of selected component (if applicable):
pm-utils-0.13-1

How reproducible:
Execute 'vbetool post' from a text console.

Steps to Reproduce:
1. ALT-CTL-F1 to get to text console. Login as root, make sure SELinux is in
Permissive mode.
2. 'vbetool post'
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2006-03-05 15:53:09 EST
Created attachment 125676 [details]
Ouput of 'strace vbetool post'
Comment 2 Tom London 2006-03-05 17:49:22 EST
In case its important, here is output from 'lspci' and 'lspci -mn':
[root@localhost pm]# lspci -m
00:00.0 "Host bridge" "Intel Corporation" "Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller" -r03 "IBM" "Unknown device 0575"
00:02.0 "VGA compatible controller" "Intel Corporation" "Mobile 915GM/GMS/910GML
Express Graphics Controller" -r03 "IBM" "Unknown device 0582"
00:02.1 "Display controller" "Intel Corporation" "Mobile 915GM/GMS/910GML
Express Graphics Controller" -r03 "IBM" "Unknown device 0582"
00:1c.0 "PCI bridge" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6 Family)
PCI Express Port 1" -r03 "" ""
00:1d.0 "USB Controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #1" -r03 "IBM" "Unknown device 0565"
00:1d.1 "USB Controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #2" -r03 "IBM" "Unknown device 0565"
00:1d.2 "USB Controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #3" -r03 "IBM" "Unknown device 0565"
00:1d.3 "USB Controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #4" -r03 "IBM" "Unknown device 0565"
00:1d.7 "USB Controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6
Family) USB2 EHCI Controller" -r03 -p20 "IBM" "Unknown device 0566"
00:1e.0 "PCI bridge" "Intel Corporation" "82801 Mobile PCI Bridge" -rd3 -p01 "" ""
00:1e.2 "Multimedia audio controller" "Intel Corporation" "82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller" -r03 "IBM" "Unknown device 0581"
00:1e.3 "Modem" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97
Modem Controller" -r03 "IBM" "Unknown device 0576"
00:1f.0 "ISA bridge" "Intel Corporation" "82801FBM (ICH6M) LPC Interface Bridge"
-r03 "IBM" "Unknown device 0568"
00:1f.2 "IDE interface" "Intel Corporation" "82801FBM (ICH6M) SATA Controller"
-r03 -p80 "IBM" "Unknown device 056a"
00:1f.3 "SMBus" "Intel Corporation" "82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller" -r03 "IBM" "Unknown device 056b"
02:00.0 "Ethernet controller" "Broadcom Corporation" "NetXtreme BCM5751M Gigabit
Ethernet PCI Express" -r11 "IBM" "Unknown device 0577"
04:00.0 "CardBus bridge" "Ricoh Co Ltd" "RL5c476 II" -r8d "IBM" "Unknown device
0555"
04:00.1 "Class 0805" "Ricoh Co Ltd" "R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter"
-r13 "IBM" "Thinkpad X40"
04:02.0 "Network controller" "Intel Corporation" "PRO/Wireless 2200BG" -r05
"Intel Corporation" "Unknown device 2711"
[root@localhost pm]# lspci -mn
00:00.0 "0600" "8086" "2590" -r03 "1014" "0575"
00:02.0 "0300" "8086" "2592" -r03 "1014" "0582"
00:02.1 "0380" "8086" "2792" -r03 "1014" "0582"
00:1c.0 "0604" "8086" "2660" -r03 "" ""
00:1d.0 "0c03" "8086" "2658" -r03 "1014" "0565"
00:1d.1 "0c03" "8086" "2659" -r03 "1014" "0565"
00:1d.2 "0c03" "8086" "265a" -r03 "1014" "0565"
00:1d.3 "0c03" "8086" "265b" -r03 "1014" "0565"
00:1d.7 "0c03" "8086" "265c" -r03 -p20 "1014" "0566"
00:1e.0 "0604" "8086" "2448" -rd3 -p01 "" ""
00:1e.2 "0401" "8086" "266e" -r03 "1014" "0581"
00:1e.3 "0703" "8086" "266d" -r03 "1014" "0576"
00:1f.0 "0601" "8086" "2641" -r03 "1014" "0568"
00:1f.2 "0101" "8086" "2653" -r03 -p80 "1014" "056a"
00:1f.3 "0c05" "8086" "266a" -r03 "1014" "056b"
02:00.0 "0200" "14e4" "167d" -r11 "1014" "0577"
04:00.0 "0607" "1180" "0476" -r8d "1014" "0555"
04:00.1 "0805" "1180" "0822" -r13 "1014" "0556"
04:02.0 "0280" "8086" "4220" -r05 "8086" "2711"
[root@localhost pm]#
Comment 3 Phil Knirsch 2006-03-06 09:41:55 EST
See my comments in https://bugzilla.redhat.com/bugzilla//show_bug.cgi?id=184033
because i think these 2 bugs are very related.

Read ya, Phil
Comment 4 Till Maas 2007-08-30 10:53:04 EDT
(In reply to comment #0)
> Description of problem:
> Running 'vbetool post' on my Thinkpad X41 produces the following:

Do you want to run 'vbetool post' for any reason other than for suspending?
Afaik you do not need it, I have an X41, too. Suspend works without vbetool, but
I never  tried hibernate.

Please try pm-suspend --quirk-s3-bios with Fedora 7 or Rawhide, this should work.
Comment 5 Tom London 2007-08-30 14:09:44 EDT
I no longer have an X41 thinkpad.  (Now I have an X60).

So I can't test this any longer.

'vbetool post' works as expected on x60.
Comment 6 Till Maas 2007-09-19 18:01:42 EDT
I did not find any reason to use vbetool except for restoring the display after
suspend. Also the vbetool manpage says, that vbetool post may not work on some
notebooks. An x41 does not need vbetool for this, therefore I close this bug as
NOTABUG. The current pm-utils in devel should make an X41 suspend flawlessly.

Note You need to log in before you can comment on or make changes to this bug.