This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 184070 - gnome-terminal doesn't scroll properly in /bin/vi
gnome-terminal doesn't scroll properly in /bin/vi
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 185204 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 16:39 EST by Alex Stewart
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.12.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:51:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of problem. (46.96 KB, image/png)
2006-03-05 16:45 EST, Alex Stewart
no flags Details

  None (edit)
Description Alex Stewart 2006-03-05 16:39:50 EST
Description of problem:

When I edit a long file in vi (note, not vim, only /bin/vi) using gnome-
terminal (TERM=xterm), the bottom line is not cleared properly when scrolling 
down, so if the next line is shorter than the previous one, part of the end of 
the previous line is still displayed at the bottom of the screen.

If I cover the window with something else and bring it back to the foreground, 
or if I attempt to select that region of the window, it will redraw it 
correctly, so this appears to be only a window drawing issue and not actually 
in the screen buffer of the terminal.

Version-Release number of selected component (if applicable):

  gnome-terminal-2.13.92-1

How reproducible:

  Always

Steps to Reproduce:
1.  Open a gnome-terminal window.
2.  Open a long file with lines of varying width in /bin/vi.
3.  Scroll down until a line that's significantly shorter than the previous 
line scrolls onto the screen.

Actual results:

  Remnants of the previous line stay on the last line of the screen when it 
scrolls up.

Expected results:

  Scrolling without leaving droppings behind.

Additional info:
Comment 1 Alex Stewart 2006-03-05 16:45:29 EST
Created attachment 125685 [details]
Screenshot of problem.

Note: last line should read only "They hadn't any feet."  The bits after that
are left over from previous lines that scrolled up.
Comment 2 Thomas J. Baker 2006-03-06 14:42:10 EST
I see this too with the terminal set to vt100.
Comment 3 Thomas Steudten 2006-04-24 08:24:03 EDT
Same problem for me with FC5 (latest updates)
gnome-terminal-2.14.1-1.fc5.1
vim-minimal-6.4.007-4

Comment 4 Thomas Steudten 2006-05-11 08:27:12 EDT
No work here?
Comment 5 Behdad Esfahbod 2006-07-27 17:51:20 EDT
Fixed already.
Comment 6 Behdad Esfahbod 2006-07-27 17:52:49 EDT
*** Bug 185204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.