Bug 184138 - evince requires password for doc, when one isn't required
evince requires password for doc, when one isn't required
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 14:22 EST by John W. Lockhart
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 10:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John W. Lockhart 2006-03-06 14:22:03 EST
Description of problem:
evince requires password for doc, when one isn't required

Version-Release number of selected component (if applicable):
evince-0.4.0-1.2.386

How reproducible:
evince DRM.pdf ; xpdf DRM.pdf

Steps to Reproduce:
1. wget 'http://www.acm.org/usacm/weblog/wp-content/DRM.pdf'
2. evince DRM.pdf ; xpdf DRM.pdf
  
Actual results:
Cannot view pdf.

Expected results:
Readable pdf.

Additional info:
Info about how more viewers behave should be
in the comments here:
http://lwn.net/Articles/174448/
(according to which, acroread doesn't require a passwd).
Comment 2 Christian Iseli 2007-01-22 06:33:27 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 3 John W. Lockhart 2007-01-22 17:49:29 EST
On FC6, it no longer prompts for a password.

Depending on the version of evince, sometimes additional
errors are printed on stderr, though:

evince-0.6.0-3.fc6.i386
Error (60112): Unknown filter 'Crypt'

evince-0.6.0-6.fc6.i386
(no error message observed)

Feel free to double-check the acm.org link, as the document is
still available.  My main machine is still, oddly enough, at FC4.
Comment 4 John W. Lockhart 2007-07-09 16:31:32 EDT
On F7: evince-0.6.0-6.fc6, no error messages arise.  Takes longer than xpdf to
load, but seems otherwise fine.  Feel free to close this one out unless you
think the load time is an issue.


Note You need to log in before you can comment on or make changes to this bug.