Bug 184149 - messed up dependencies for namazu when 'yum update'ing after upgrading to FC5t3
messed up dependencies for namazu when 'yum update'ing after upgrading to FC5t3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: namazu (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 16:12 EST by Przemek Klosowski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.15-3.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 22:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2006-03-06 16:12:33 EST
Description of problem:

After upgrading to FC5test3 on an i386 box, and subsequent 'yum update'
against the following repositories 
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/Fedora/RPMS
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/development/i386/RPMS


I get failed ependencies for packages namazu, licq and koffice
I lost the error messages, but namazu depended on perl, licq
on other licq-* components and koffice on koffice-devel.

I tried but failed to force the upgrade by 'yum upgrade koffice-devel'
and similar tricks; in the end, I had to 

rpm -e namazu{,-devel,-cgi} licq{,-kde,-text,-qt,-gnome} koffice{,-i18n,-devel}

and after that 'yum update' seems to be working fine.
Comment 1 Przemek Klosowski 2006-03-07 11:16:25 EST
on subsequent 'yum update' more Missing Dependency errors:
javamail >=20031006-4 is needed by mx4j-tools
javamail = 20031006-4 is needed by javamail-devel
bcel = 5.0-13 is needed by bcel-devel
jaf = 20030319-4 is needed by jaf-devel
They appear after 'Running transaction check'/'Processing Dependency'/Finished
Dependency Resolution' steps.

I don't currently have javamail installed, but have javamail-devel, for unknown
reasons. Same thing for jaf (have jaf-devel, but no jaf). I have both bcel and
bcel-devel.
After 'rpm -e jaf-devel javamail-devel mx4j-tools bcel-devel' 'yum update' worked
Comment 2 Przemek Klosowski 2006-03-07 14:35:33 EST
I tried to reinstall the packages I had to take out to get past the dependencies
problem. koffice is not there, and needs to be replaced by koffice-suite.
jaf-devel javamail-devel mx4j-tools bcel-devel aren't available, and I don't care
about them so I didn't try to find out the new package names.

namazu won't load: the error is (again after transaction check/dependency
resolution steps, 
Error: Missing Dependency: perl(conf.pl) is needed by package namazu
(and four more messages like that, referring to perl(var.pl, time.pl,
document.pl and util.pl). As far as I can tell, this is the same dependency
error that 
prevented an upgrade in the first place.
Comment 3 Akira TAGOH 2006-03-07 23:55:27 EST
complaining the packages except namazu isn't suitable here. please file a
separate bug if you didn't.
Comment 4 Akira TAGOH 2006-03-08 22:41:34 EST
should be fixed in 2.0.15-3.fc5

Note You need to log in before you can comment on or make changes to this bug.