Bug 184171 - Please add remaining language binding rpms to Extras distro
Please add remaining language binding rpms to Extras distro
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 18:20 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.8-4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 22:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2006-03-06 18:20:06 EST
Description of problem:
Graphviz src.rpm generates some additional language binding rpms that are
currently missing from the Extras distribution:
  graphviz-guile
  graphviz-java
  graphviz-lua
  graphviz-ocaml
  graphviz-perl
  graphviz-php
  graphviz-python
  graphviz-ruby

Version-Release number of selected component (if applicable):
graphviz-2.8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Lancaster 2006-09-14 11:38:49 EDT
+1.  I think these just need to be added as BuildRequires: (and tested, of
course) and also the %define's in the spec file below should be set to "1".

%define SHARP   0
%define GUILE   0
%define _IO     0
%define JAVA    0
%define LUA     0
%define OCAML   0
%define PERL    0
%define PHP     0
%define PYTHON  0
%define RUBY    0
%define TCL     1

(PS.  I had to remove the "FutureFeature" keyword because Bugzilla wouldn't
allow me to leave it there!)
Comment 2 Alex Lancaster 2006-09-14 15:12:54 EDT
This will probably be fixed by fixing bug #188148.
Comment 3 Jima 2006-09-14 22:07:04 EDT
Yes, Alex, it was. :-)

For everyone else's reference, Alex came into #fedora-extras this morning
looking for help on bug #188148, and I rolled an update which fixes that and
this bug.

(The -io subpackage will have to wait until Fedora has Io, though, as discussed
on IRC.)

Note You need to log in before you can comment on or make changes to this bug.