Bug 184203 - metacity crashes on exit, null pointer dereference
metacity crashes on exit, null pointer dereference
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
All Linux
high Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 02:11 EST by Denis Leroy
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 15:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Finding continously metacity core file (FC5 Gnome session) in my home dir (athlon xp32000+). (762.71 KB, application/octet-stream)
2006-05-10 01:22 EDT, Joachim Backes
no flags Details

  None (edit)
Description Denis Leroy 2006-03-07 02:11:49 EST
I keep discovering metacity core files in my home directory. I didn't notice the
crash, so this might happen during logout (?). Backtrace :

#0  meta_compositor_unref (compositor=0x0) at compositor.c:162
162       if (compositor->repair_idle)
(gdb) bt
#0  meta_compositor_unref (compositor=0x0) at compositor.c:162
#1  0x0805e030 in meta_display_close (display=0x99f7408) at display.c:926
#2  0x080707cc in main (argc=1, argv=0xbff0a2f4) at main.c:505
#3  0x005b37e4 in __libc_start_main () from /lib/libc.so.6
#4  0x08053971 in _start ()
(gdb) p compositor
$1 = (MetaCompositor *) 0x0
Comment 1 Scott Tsai 2006-03-10 08:01:09 EST
I'm seeing this as well, some additional info from gdb:
Core was generated by `metacity --sm-save-file 1141988313-15132-3103535370.ms'.
Program terminated with signal 11, Segmentation fault.

warning: .dynamic section for "/usr/lib64/libstdc++.so.6" is not at the expected
address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib64/libgcc_s.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations
Comment 2 Denis Leroy 2006-03-11 18:58:00 EST
In my case, the core was generated by '/usr/bin/metacity --sm-client-id=default1'

This is still happening with metacity-2.13.144-1
Comment 3 Denis Leroy 2006-04-13 12:57:18 EDT
Still happening with 2.14.2-1.fc5.2
Comment 4 Søren Sandmann Pedersen 2006-04-25 12:27:55 EDT
Denis, Scott, what architectures are you using?
Comment 5 Denis Leroy 2006-04-25 13:34:37 EDT
This is i386. I have a dual Athlon board.
Comment 6 Scott Tsai 2006-04-25 15:58:25 EDT
I'm on x86_64, dual core intel Pentium D.
I can still trigger this reliably with metacity-2.14.3-1.fc5.1 by checking the
"Save current setup" toggle box on logout.
Comment 7 Joachim Backes 2006-05-10 01:22:23 EDT
Created attachment 128833 [details]
Finding continously metacity core file (FC5 Gnome session) in my home dir (athlon xp32000+).
Comment 8 Denis Leroy 2006-08-09 10:53:30 EDT
Still happening with FC-5 updated (also on i386 T30 thinkpad). Appears fixed in
FC6-2.

Reproducable: always.
Steps to reproduce: log out of Gnome.
 
Comment 9 Matthias Clasen 2006-08-13 10:41:54 EDT
Definitively fixed in FC6 by moving to a compositor-less metacity. 

Note You need to log in before you can comment on or make changes to this bug.