Bug 184215 - wrong code with -O2 (d1mach.f)
wrong code with -O2 (d1mach.f)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 08:23 EST by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-01 06:22:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2006-03-07 08:23:30 EST
Description of problem:   
   
d1mach.f produces wrong code with -O2.  This may be the same as  
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=18518, which was reportedly fixed.  
gfortran -O2 d1mach.f  && ./a.out  
  
 Adjust D1MACH by uncommenting data statements  
 appropriate for your machine.  
STOP 779  
g77 -O2 d1mach.f  && ./a.out  
  2.22507386E-308  
  1.79769313E+308  
  1.11022302E-16  
  2.22044605E-16  
  0.301029996  
gfortran -O d1mach.f  && ./a.out  
  2.225073858507201E-308  
  1.797693134862316E+308  
  1.110223024625157E-016  
  2.220446049250313E-016  
  0.301029995663981  
  
Version-Release number of selected component (if applicable):   
 gcc-4.1.0-2  
   
How reproducible:   
   
 every time  
Steps to Reproduce:   
1. see above  
2.   
3.   
     
Actual results:   
   
   
Expected results:   
   
   
Additional info:   
I rate this as high priority because it is used by various packages, such as 
scipy so it causes a lot of breakage.
Comment 2 Jakub Jelinek 2006-04-01 06:22:27 EST
Fixed in rawhide gcc-4.1.0-4, whenever FC5 updates are made it will be there too.

Note You need to log in before you can comment on or make changes to this bug.