Bug 184269 - /etc/init.d/iscsi reload does not remove old targets.
/etc/init.d/iscsi reload does not remove old targets.
Status: CLOSED DUPLICATE of bug 184262
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 14:08 EST by Wayne Berthiaume
Modified: 2008-04-07 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 15:27:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wayne Berthiaume 2006-03-07 14:08:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; InfoPath.1)

Description of problem:
If you change the discovery addresses in the /etc/iscsi.conf file then perform an /etc/init.d/iscsi reload, the new target is loaded in; however, the old target that was removed from the configuration file remains.

Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.2.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Configure /etc/iscsi.conf with a set of targets
2. Start driver and insure all targets are discovered with iscsi-ls
3. Edit /etc/iscsi.conf and remove one target and add a new target
4. Execute /etc/init.d/iscsi reload
5. iscsi-ls
  

Actual Results:  The new target is discovered; however, the old target still remains when you issue the iscsi-ls() command.

Expected Results:  You would expect that after the rescan the old target would be removed and the new target added.

Additional info:

 iscsi-initiator-utils-4.0.3.0-2
 SFNet iSCSI Driver Version ...4:0.1.11(12-Jan-2005)
Comment 1 David Lawrence 2006-03-07 15:27:20 EST

*** This bug has been marked as a duplicate of 184262 ***

Note You need to log in before you can comment on or make changes to this bug.