Bug 184286 - Misleading error message with IPv6 scan
Misleading error message with IPv6 scan
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nmap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 15:37 EST by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: nmap-4.03-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 09:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2006-03-07 15:37:54 EST
Description of problem:
nmap issues a misleading error message with some IPv6 options

Version-Release number of selected component (if applicable):
nmap-4.00-1.2

How reproducible:


Steps to Reproduce:
1.  nmap -sT -O -PI -PT -T4 -6 ::1
2.
3.
  
Actual results:

# nmap -sT -O -PI -PT -T4 -6 ::1
Sorry -- IPv6 support is currently only available for connect() scan (-sT), ping
scan (-sP), and list scan (-sL).  Further support is under consideration.
QUITTING!

Expected results:
The error message shouldn't complain about -sT, which was specified, but
should instead say something about the -O option for operating system
fingerprinting, which isn't supported for IPv6....

Additional info:
Comment 1 Valdis Kletnieks 2006-03-07 17:21:49 EST
Fyodor says it will be fixed in the next upstream release...
Comment 2 Karsten Hopp 2006-05-10 09:10:53 EDT
Updated packages are ony their way to the mirrors. The message wording has been
enhanced to say something about fingerprinting.

Note You need to log in before you can comment on or make changes to this bug.