Bug 184313 - yum - silent and destructive change in behaviour with respect to caches
yum - silent and destructive change in behaviour with respect to caches
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 17:41 EST by Michal Jaegermann
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 17:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-03-07 17:41:12 EST
Description of problem:

With a freshly updated yum running 'yum update' silently and unexpectedly
cleans caches (which was really undesirable here).  Digging through recent
ChangeLog and 'man yum.conf' one can find about a new option 'keepcache'
and this:

       keepcache
              Either ‘1’ or ‘0’. Determines whether or not yum keeps the cache
              of  headers  and packages after succesful installation.  Default
              is ’1’ (keep files)

So far so good but it turns out that /etc/yum.conf was quietly replaced and,
SURPRISE, it has 'keepcache=0' in it.

At least some kind of a warning during an installation would be expected.

Version-Release number of selected component (if applicable):
yum-2.6.0-1
Comment 1 Jeremy Katz 2006-03-07 17:47:29 EST
You're updating in the rawhide tree.  It eats babies.

There will be something in the final FC5 release notes to mention this change in
behavior from previous releases.

Note You need to log in before you can comment on or make changes to this bug.