Bug 184354 - Users must be able to change passwords from squirrelmail
Users must be able to change passwords from squirrelmail
Status: CLOSED DUPLICATE of bug 184355
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 01:03 EST by Razvan Sandu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 03:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Razvan Sandu 2006-03-08 01:03:08 EST
Description of problem:

On a stock Fedora Core 4 system + updates I am using Postfix (with virtual
users), dovecot & squirrelmail.

Dovecot's IMAP passwords are located in /etc/imap.passwd (or any other text file
which is not /etc/passwd) - that's because Postfix users are *virtual* users, so
e-mail accounts are separated from system accounts.

Various plugins for squirrelmail do exist, allowing users to change their
passwords by themselves, if passwords are stored in /etc/passwd, MySQL, LDAP, etc.

A way to change the password through the Web interface should exist, if
passwords are stored in a passwd-like text file different from /etc/passwd.

The solution should be SELinux-aware.


Version-Release number of selected component (if applicable):

postfix-2.2.2-2
dovecot-0.99.14-4.fc4
selinux-policy-targeted-1.27.1-2.22


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Razvan Sandu 2006-03-08 03:17:33 EST

*** This bug has been marked as a duplicate of 184355 ***

Note You need to log in before you can comment on or make changes to this bug.