Bug 184358 - unable to input indic if OOo starts from non-indic locale
unable to input indic if OOo starts from non-indic locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 02:28 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 10:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-03-08 02:28:14 EST
Description of problem:
Interestingly, if I log in to the system with CJK locale and start oowriter from
gnome-terminal in any of the five supported indic locales, scim cannot be
started. Seems Ctrl-SPACE used to activate SCIM is ignored. On the other hand,
if I am in ja locale and I started oowriter with ko locale, everything still
works properly.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.2-5.1.2
scim-1.4.4-8

How reproducible:
Always

Steps to Reproduce:
1.log in with CJK locale at gdm
2.in g-t, start oowriter in {bn,hi}_IN locale, LANG=bn_IN.UTF-8 oowriter
3.ctrl-SPACE to activate SCIM
  
Actual results:
Nothing happens. Cant input in indic

Expected results:
Should be able to input indic ok.

Additional info:
Comment 1 Caolan McNamara 2006-03-08 04:37:36 EST
how about with 
> export GTK_IM_MODULE=scim
from the terminal ?

does e.g. gedit behave differently than OOo under the same circumstances ?
Comment 2 Lawrence Lim 2006-03-15 01:07:23 EST
RE: Comment #1

Apologies for the delay.

I dont think its the issue with setting GTK_IM_MODULE because if logged into the
system with CJK locale, everything is working fine. However, just for you, I
exported the env again explicitly to see if it turns out better. :-)

System Locale: ja_JP.UTF-8
# LANG=zh_CN.UTF-8 GTK_IM_MODULE=scim oowriter (OK)
# LANG=zh_CN.UTF-8 oowriter (OK)

# LANG=hi_IN.UTF-8 oowriter (not OK)
# LANG=hi_IN.UTF-8 GTK_IM_MODULE=scim oowriter (not OK)
Comment 3 Lawrence Lim 2006-03-15 01:08:46 EST
# LANG=hi_IN.UTF-8 gedit works fine too without explicitly setting GTK_IM_MODULE.
Comment 4 Caolan McNamara 2006-05-23 05:11:21 EDT
This (I assume) has no connection to bug 192175 i.e. scim vs scim-bridge ?
Comment 5 Akira TAGOH 2006-05-23 06:25:53 EDT
(In reply to comment #4)
> This (I assume) has no connection to bug 192175 i.e. scim vs scim-bridge ?

I don't think so. even if default was GTK_IM_MODULE=scim-bridge, he already
tried GTK_IM_MODULE=scim as he told at Comment #2.
Comment 6 Akira TAGOH 2006-05-23 06:44:28 EDT
I've also tried this with the following environment, it works for me.

$ locale
LANG=ko_KR.UTF-8
LC_CTYPE="ko_KR.UTF-8"
LC_NUMERIC="ko_KR.UTF-8"
LC_TIME="ko_KR.UTF-8"
LC_COLLATE="ko_KR.UTF-8"
LC_MONETARY="ko_KR.UTF-8"
LC_MESSAGES="ko_KR.UTF-8"
LC_PAPER="ko_KR.UTF-8"
LC_NAME="ko_KR.UTF-8"
LC_ADDRESS="ko_KR.UTF-8"
LC_TELEPHONE="ko_KR.UTF-8"
LC_MEASUREMENT="ko_KR.UTF-8"
LC_IDENTIFICATION="ko_KR.UTF-8"
LC_ALL=
$ rpm -qa | grep scim
scim-tables-0.5.6-5
scim-hangul-0.2.2-3.fc6
scim-qtimm-0.9.4-3
scim-anthy-1.0.0-2.fc6.1
scim-m17n-0.2.0-3
scim-chewing-0.2.1-6
scim-bridge-0.1.8-17
scim-libs-1.4.4-17
scim-1.4.4-17
scim-pinyin-0.5.91-5
scim-tables-chinese-0.5.6-5
scim-devel-1.4.4-17
$ rpm -qa | grep openoffice
openoffice.org-impress-2.0.3-2.1
openoffice.org-langpack-da_DK-2.0.3-2.1
openoffice.org-langpack-ga_IE-2.0.3-2.1
openoffice.org-langpack-ja_JP-2.0.3-2.1
openoffice.org-langpack-pl_PL-2.0.3-2.1
openoffice.org-langpack-ta_IN-2.0.3-2.1
openoffice.org-langpack-bg_BG-2.0.3-2.1
openoffice.org-langpack-es-2.0.3-2.1
openoffice.org-langpack-he_IL-2.0.3-2.1
openoffice.org-langpack-ms_MY-2.0.3-2.1
openoffice.org-langpack-ru-2.0.3-2.1
openoffice.org-langpack-zh_TW-2.0.3-2.1
openoffice.org-draw-2.0.3-2.1
openoffice.org-langpack-ar-2.0.3-2.1
openoffice.org-langpack-cs_CZ-2.0.3-2.1
openoffice.org-langpack-el_GR-2.0.3-2.1
openoffice.org-langpack-fi_FI-2.0.3-2.1
openoffice.org-langpack-gu_IN-2.0.3-2.1
openoffice.org-langpack-hu_HU-2.0.3-2.1
openoffice.org-langpack-lt_LT-2.0.3-2.1
openoffice.org-langpack-nn_NO-2.0.3-2.1
openoffice.org-langpack-pt_PT-2.0.3-2.1
openoffice.org-langpack-sr_CS-2.0.3-2.1
openoffice.org-langpack-zh_CN-2.0.3-2.1
openoffice.org-xsltfilter-2.0.3-2.1
openoffice.org-calc-2.0.3-2.1
openoffice.org-langpack-af_ZA-2.0.3-2.1
openoffice.org-langpack-ca_ES-2.0.3-2.1
openoffice.org-langpack-de-2.0.3-2.1
openoffice.org-langpack-eu_ES-2.0.3-2.1
openoffice.org-langpack-gl_ES-2.0.3-2.1
openoffice.org-langpack-hr_HR-2.0.3-2.1
openoffice.org-langpack-ko_KR-2.0.3-2.1
openoffice.org-langpack-nl-2.0.3-2.1
openoffice.org-langpack-pt_BR-2.0.3-2.1
openoffice.org-langpack-sl_SI-2.0.3-2.1
openoffice.org-langpack-th_TH-2.0.3-2.1
openoffice.org-writer-2.0.3-2.1
openoffice.org-core-2.0.3-2.1
openoffice.org-langpack-bn-2.0.3-2.1
openoffice.org-langpack-et_EE-2.0.3-2.1
openoffice.org-langpack-hi_IN-2.0.3-2.1
openoffice.org-langpack-nb_NO-2.0.3-2.1
openoffice.org-langpack-sk_SK-2.0.3-2.1
openoffice.org-math-2.0.3-2.1
openoffice.org-graphicfilter-2.0.3-2.1
openoffice.org-langpack-cy_GB-2.0.3-2.1
openoffice.org-langpack-fr-2.0.3-2.1
openoffice.org-langpack-it-2.0.3-2.1
openoffice.org-langpack-pa_IN-2.0.3-2.1
openoffice.org-langpack-sv-2.0.3-2.1
$ echo $GTK_IM_MODULE
scim-bridge
$ LANG=hi_IN.UTF-8 oowriter
(scim panel appeared with ctrl+space)
$ LANG=hi_IN.UTF-8 GTK_IM_MODULE=scim oowriter
(scim panel appeared with ctrl+space)
$ LANG=bn_IN.UTF-8 oowriter
(scim panel appeared with ctrl+space)
$ LANG=bn_IN.UTF-8 GTK_IM_MODULE=scim oowriter
(scim panel appeared with ctrl+space)

Lawrence, can you test this again?
Comment 7 A S Alam 2006-05-23 10:02:55 EDT
yes, working fine for latest Build as you mention.
Test Environment:
as in Comment#6

Note You need to log in before you can comment on or make changes to this bug.