Bug 184370 - get ugly message (not responding) if I try to close a "edit mail" window
get ugly message (not responding) if I try to close a "edit mail" window
Status: CLOSED DUPLICATE of bug 184369
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 05:02 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 02:02:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-03-08 05:02:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.0.1) Gecko/20060306 Fedora/1.5.0.1-7 Firefox/1.5.0.1

Description of problem:
If I write a mail and try to close it using the system menu (cross in the upper right corner of the window) I get a first dialog which says "You changed something" (I have the german version so I don't know how it is written in the english version in German it is "Warnung: Geänderte Nachricht").
This is still ok, but about 2 seconds later I get another dialog window, which says, that the message window is not responding (Title: Warnung Message: Das Fenster >>yoursubject<< reagiert nicht).

This second window should not occur, because the window doesn't hang, it is just waiting for user input. I don't know if this is a general problem in gnome event handling or if it is just an event which should be handeled by evolution, but isn't at the moment. I suppose the last is the reason.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open evolution
2. create a new mail
3. type something
4. try to close the window using the system menu (upper right corner in the title bar)
5. wait until you see the two message dialogs (should happen within 5 seconds)
  

Actual Results:  gnome seems to think the window doesn't respond to the "system menu close"-event and displays a message to resolve the situation.

Expected Results:  The close event obviously is hadeled so this second message is not necessary. Evolution is just waiting for user interaction

Additional info:

It's not critical, but it is ugly. At first I thought Evolution would really hang. For an inexperienced user this looks like a fatal error occured. It will probably also lead to thinking that evolution is not stable software, which I think is not true of course. Evolution is great :o)
...and FC5 too, of course. Except for the devicemapper- and bootloader-install hell, I had to go through several times :o(
I was surprised how much faster FC5 starts up. Also after login the session is available faster.
Comment 1 Frank Arnold 2006-03-09 02:02:46 EST

*** This bug has been marked as a duplicate of 184369 ***

Note You need to log in before you can comment on or make changes to this bug.