Bug 184373 - Pirut crashes on a i386 box when installing FC5 or after that.
Pirut crashes on a i386 box when installing FC5 or after that.
Status: CLOSED DUPLICATE of bug 182360
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 05:21 EST by Baif
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 12:26:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baif 2006-03-08 05:21:12 EST
Description of problem:   
Right click the mouse on group List(or else listbox) raises unexpected error.  
  
DO NOTICE on a i386 box when installing FC5 or after that. 
  
Version-Release number of selected component (if applicable):   
     Name        : pirut                        Relocations: (not relocatable)   
Version    : 0.9.10                            Vendor: Red Hat, Inc.   
Release    : 1                            Build Date: Sat 04 Feb 2006 01:55:16  
PM CST  
   
How reproducible:   
   
   
Right click the mouse on a item of any listbox.  DO NOTICE on a i386 box.  
    DO NOTICE on a i386 box when installing FC5 or after that. 
 
   
Additional info:   
 
 
    Component: Software Manager   
Summary: TBf5bc6e9a GroupSelector.py:449:__doGroupPopup:OverflowError: can't  
convert negative value to unsigned long   
   
Traceback (most recent call last):   
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 461, in  
_groupListButtonPress   
    self.__doGroupPopup(event.button, long(event.time))   
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 449, in  
__doGroupPopup   
    menu.popup(None, None, None, button, time)   
OverflowError: can't convert negative value to unsigned long   
   
Local variables in innermost frame:   
menu: <gtk.Menu object (GtkMenu) at 0xb6b3902c>   
button: 3   
self: <pirut.GroupSelector.GroupSelector instance at 0xb78fc28c>   
time: -648574417
Comment 1 Baif 2006-03-08 06:08:41 EST
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py" 
    
    447    def __doGroupPopup(self, button, time):   
    448        menu = self.groupMenu   
    449        menu.popup(None, None, None, button, time)   
    450        menu.show_all()   
    451    
    452    def _groupListButtonPress(self, widget, event):   
    453        if event.button == 3:   
    454            x = int(event.x)   
    455            y = int(event.y)   
    456            pthinfo = widget.get_path_at_pos(x, y)   
    457            if pthinfo is not None:   
    458                path, col, cellx, celly = pthinfo   
    459                widget.grab_focus()   
    460                widget.set_cursor(path, col, 0)   
    461                self.__doGroupPopup(event.button, long(event.time))   
    462            return 1  
Comment 2 Baif 2006-03-08 06:11:13 EST
    Name        : python                      Relocations: (not relocatable)  
Version    : 2.4.2                            Vendor: Red Hat, Inc.  
Release    : 3.2.1                        Build Date: Sun 12 Feb 2006 05:05:12 
PM CST  
Install Date: Fri 24 Feb 2006 02:47:34 PM CST      Build Host: 
hs20-bc1-1.build.redhat.com  
Arch: i386 
 
    Name        : pygtk2                      Relocations: (not relocatable)  
Version    : 2.8.4                            Vendor: Red Hat, Inc.  
Release    : 1.1                          Build Date: Thu 09 Feb 2006 02:20:42 
AM CST  
Install Date: Fri 24 Feb 2006 02:56:38 PM CST      Build Host: 
hs20-bc1-6.build.redhat.com  
Group      : Development/Languages        Source RPM: pygtk2-2.8.4-1.1.src.rpm  
Arch: i386 
 
 
Comment 3 Jeremy Katz 2006-03-09 12:26:27 EST

*** This bug has been marked as a duplicate of 182360 ***

Note You need to log in before you can comment on or make changes to this bug.