Bug 184407 - parted print does not always show that a partition contains an ext3 fs [NEEDINFO]
parted print does not always show that a partition contains an ext3 fs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 11:27 EST by bastiaan
Modified: 2008-09-24 08:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 08:38:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
atodorov: needinfo? (bastiaan)


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2006-03-08 11:27:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
'parted /dev/sdX print' outputs a list with all partitions on the specified disk. The list contains a column 'Filesystem' that shows which filesystem is installed on the partition.
However for some disks parted fails to show that a partition contains an (ext3) filesystem.
 

Version-Release number of selected component (if applicable):
1.6.19-1.EL

How reproducible:
Always

Steps to Reproduce:
1. parted /dev/sdah print
2.
3.
  

Actual Results:  Disk geometry for /dev/sdah: 0.000-143370.000 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.016 143370.000  primary


Expected Results:  Disk geometry for /dev/sdah: 0.000-143370.000 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.016 143370.000  primary   ext3


Additional info:

fdisk -l output:
Disk /dev/sdah: 150.3 GB, 150334341120 bytes
64 heads, 32 sectors/track, 143370 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

    Device Boot      Start         End      Blocks   Id  System
/dev/sdah1               1      143370   146810864   83  Linux

The disk is a SAN snapshot of a volume in use on a RHEL3 box. Parted does show the filesystem information for a SAN snapshot of another volume used by the same system.
Comment 1 RHEL Product and Program Management 2007-11-28 23:26:13 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Joel Andres Granados 2008-05-26 09:42:44 EDT
Is this an issue that was introduced in recent versions of RHEL4?.  If so, what
version of parted worked?  What I want to address in this question is the time
in which the bug was introduced.  Going from 3 to 4 doesn't give me a lot of
information on where the bug might be as a *lot* of changes happened from one
release to another.  Did you see it in RHEL4.{1,2,3,4,5,6,7}

Is it possible for you to attach the first 1024 bytes of the image.  this might
be useful in debugging the situation.
Comment 4 bastiaan 2008-05-26 09:58:59 EDT
Hi Joel, 

This issue was not introduced in recent versions of RHEL4. As you can see the
bug was filed in March 2006 against parted 1.6.19-1.EL. I don't know exactly
which RHEL release that is but I suspect RHEL4 <= 4.2. 
Unfortunately the affected configuration is not available anymore for me to test
with, so I cannot send you the first 1k of the image.

Comment 5 Joel Andres Granados 2008-06-10 10:59:45 EDT
very similar issue in 52 250717
Comment 7 Alexander Todorov 2008-09-03 06:55:55 EDT
I can't reproduce this bug. Can you post consistent steps to reproduce? 
What's on the disk, what's the disk layout (LVM, partitions, etc.) ? 
We need more information in order to address this issue.
Comment 9 RHEL Product and Program Management 2008-09-24 08:38:47 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.