Bug 184476 - banshee doesn't start
banshee doesn't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 23:29 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 07:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-03-08 23:29:50 EST
Description of problem:

$ banshee
Warning: [03/09/2006 13:33:37] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Player Engine `Helix Framework Engine (hxclientkit)' failed init tests...
disabling (Couldn't create player)
Debug: [03/09/2006 13:33:37] (Changed active playback engine) - GStreamer 0.10
Debug: [03/09/2006 13:33:37] (Loaded primary playback engine) - GStreamer 0.10
Debug: [03/09/2006 13:33:37] (Loaded Audio CD playback engine) - GStreamer 0.10
Debug: [03/09/2006 13:33:38] (Audio CD Core Initialized) -
Warning: [03/09/2006 13:33:38] (Could not connect to D-Bus) - D-Bus support will
be disabled for this instance: Object reference not set to an instance of an object
Building initial DAAP database from local library...
Starting DAAP Server
28170: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 978 function _dbus_connection_acquire_io_path

Version-Release number of selected component (if applicable):
0.10.7-1

How reproducible:
always

Steps to Reproduce:
1. $banshee
2.
3.
  
Actual results:


Expected results:


Additional info:
dbus-0.61-3
Comment 1 Christopher Aillon 2006-03-09 14:33:25 EST
Looking into this.  So far, have been unable to reproduce.  Can you also yum
install libipoddevice and see if that helps?
Comment 2 sangu 2006-03-09 20:02:02 EST
After installing libipoddevice, this problem was fixed.

Thank you.
Comment 3 sangu 2006-03-10 05:14:29 EST
This problem happens again.

$ banshee
Warning: [03/10/2006 19:17:55] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Player Engine `Helix Framework Engine (hxclientkit)' failed init tests...
disabling (Couldn't create player)
Debug: [03/10/2006 19:17:56] (Changed active playback engine) - GStreamer 0.10
Debug: [03/10/2006 19:17:56] (Loaded primary playback engine) - GStreamer 0.10
Debug: [03/10/2006 19:17:56] (Loaded Audio CD playback engine) - GStreamer 0.10
Debug: [03/10/2006 19:17:56] (Audio CD Core Initialized) -
Warning: [03/10/2006 19:17:57] (Could not connect to D-Bus) - D-Bus support will
be disabled for this instance: Object reference not set to an instance of an object
Building initial DAAP database from local library...
Starting DAAP Server
14184: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 978 function _dbus_connection_acquire_io_path

mono 1.13.4-2
libipoddevice-0.4.1-1
banshee-0.10.7-1
Comment 4 sangu 2006-05-04 07:18:21 EDT
Updating libipoddevice-0.4.5-1.fc6, this problem doesn't happen.

banshee-0.10.8-1 
mono-core-1.1.13.7-2

Note You need to log in before you can comment on or make changes to this bug.