Bug 184496 - Random crashes - trying to reply to a message prints most of a blank screen
Random crashes - trying to reply to a message prints most of a blank screen
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squirrelmail (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 05:56 EST by Graham Leggett
Modified: 2008-12-09 09:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 09:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2006-03-09 05:56:06 EST
When attempting to use Squirrelmail against a courier-imap backend on another
server, attempts to reply to messages cause the top menu to be displayed, and
the rest of the screen is blank.

Looking at the source of the page, this is as much as is printed below - the
screen is cut off after </table><br>.

No error message is printed to the screen.

The IMAP server works normally using Thunderbird.

<body text="#000000" bgcolor="#FFFFFF" link="#8888FF" vlink="#8888FF"
alink="#8888FF" onload="checkForm();">

<a name="pagetop"></a>

<table bgcolor="#FFFFFF" border="0" width="100%" cellspacing="0" cellpadding="2">
<tr bgcolor="#D0EAFF">
<td align="left">
         Current Folder: <b>INBOX&nbsp;</b>
      </td>
<td align="right"><b>
<a href="/webmail/src/signout.php" target="_top">Sign Out</a></b></td>
   </tr>
<tr bgcolor="#FFFFFF">
<td align="left">
<a
href="/webmail/src/compose.php?mailbox=INBOX&amp;startMessage=1">Compose</a>&nbsp;&nbsp;

<a href="/webmail/src/addressbook.php">Addresses</a>&nbsp;&nbsp;
<a href="/webmail/src/folders.php">Folders</a>&nbsp;&nbsp;
<a href="/webmail/src/options.php">Options</a>&nbsp;&nbsp;
<a href="/webmail/src/search.php?mailbox=INBOX">Search</a>&nbsp;&nbsp;
<a href="/webmail/src/help.php">Help</a>&nbsp;&nbsp;
<a href="/webmail/plugins/calendar/calendar.php"
target="right">Calendar</a>&nbsp;&nbsp;
      </td>
<td align="right">
<a href="http://www.squirrelmail.org/" target="_blank">SquirrelMail</a></td>

   </tr>
</table><br>
Comment 1 Graham Leggett 2006-03-09 05:56:51 EST
Squirrelmail version is 1.4.3a-12.EL4.
Comment 2 Warren Togami 2006-03-09 10:43:52 EST
I suspect that /etc/php.ini default settings are not great for squirrelmail. 
Have you tried raising the "memory_limit" option?  I personally use "32M".
Comment 3 Graham Leggett 2006-03-17 16:32:46 EST
I found reports of "out of memory" inside the server's generic eror_log, and I
raised the memory, and the crashes have reduced but not disappeared.

Now the following is logged in the virtual host's error_log file:

[Fri Mar 17 15:35:22 2006] [error] [client yy] PHP Notice:  Object of
 class ContentType could not be converted to int in /usr/share/squirrelmail/clas
s/mime/Rfc822Header.class.php on line 61, referer: https://yy/webmail/
src/right_main.php?PG_SHOWALL=0&sort=0&startMessage=1&mailbox=INBOX.Funny+Stuff
[Fri Mar 17 15:35:22 2006] [error] [client yy] PHP Notice:  Trying to
 get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.
php on line 676, referer: https://yy/webmail/src/right_main.php?PG_SHO
WALL=0&sort=0&startMessage=1&mailbox=INBOX.Funny+Stuff
[Fri Mar 17 15:35:22 2006] [error] [client yy] PHP Notice:  Trying to
 get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.
php on line 676, referer: https://yy/webmail/src/right_main.php?PG_SHO
WALL=0&sort=0&startMessage=1&mailbox=INBOX.Funny+Stuff
Comment 4 Trond Eivind Glomsrød 2006-08-01 05:10:32 EDT
The OOM crashes happen a lot on a fresh RHEL4 U3.
Comment 5 Warren Togami 2006-08-01 11:51:10 EDT
I still have not seen any signs of problems like this.

Out of curiosity, does "setenforce 0" temporarily cause this to no longer fail?
Comment 6 Trond Eivind Glomsrød 2006-08-01 14:43:09 EDT
Since the httpd runs unconfined (to get password change and vacation to work
properly from squirrelmail), this should not be an issue. There were also no
SELinux log entried.

I did specify that it was a OOM scenario, though - the default limit of 8 M does
not seem to be a usable default.

The logs were filled with messages like these before the limit was upped:

 PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to
allocate 83 bytes) in /usr/share/squirrelmail/src/compose.php on line 841, referer:
Comment 7 Tomas 2007-01-28 00:30:14 EST
I suspect that you are using PHP 5.1.4 or newer version with old SquirrelMail
version. Your notices can be reproduced only in PHP 5.1.4+. SquirrelMail fixed
PHP 5.1.4+ issues in 1.4.6 package. Some 1.4.6 updates fix fatal PHP errors.
These errors can be triggered by message priority headers and break message listing.

Make sure that you can reproduce your issue in latest SquirrelMail packages and
make sure that you have server side sorting turned on in SquirrelMail
configuration. Default PHP based sorting hits memory limits on folders with 2-3
thousand and more messages.

You can turn on server side sorting in SquirrelMail configuration utility 4.
General Options menu section. It should not cause any issues, if you use dovecot
or courier-imap compiled with --enable-unicode option. Cyrus IMAP will have
server side sorting issues only in Korean translation.

Comment 8 Martin Bacovsky 2007-05-30 13:21:44 EDT
Can you still reproduce this issue with updated squirrelmail (>= 1.4.6)?
Comment 9 Michal Hlavinka 2008-12-09 09:33:41 EST
closing this bug because of one and half year long needinfo status

Note You need to log in before you can comment on or make changes to this bug.