Bug 184501 - Gnome throws error dialog about xkbdata
Gnome throws error dialog about xkbdata
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 06:33 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 04:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-03-09 06:33:09 EST
A couple of days ago I did a full update 2 rawhide (which I do about once a
week) and today I logged out and in again for the first time since this update,
now I get a gnome error dialog about it not being able to set the kxbdata I
don't have the exact error I can write it down if you want.

My keyboard was set to plain pc104 us_intl with english as language, the only
thing special is that I had right-alt set to compose since as a european I
sometimes need special chars.

I've not tried rerunning preferences->keyboard because I want to preserve the
problem for your debugging pleasure.

Also I've not got any keyboard panel applets.
Comment 1 Mike A. Harris 2006-03-10 19:42:35 EST
Please file a bug report in the X.Org bugzilla located at
http://bugs.freedesktop.org in the "xkeyboard-config" component for this
issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 2 Hans de Goede 2006-03-11 06:58:09 EST
Erm,

I'm not sure going upstream is a good idea, esp. since I discoverd yesterday
that this does not always happen. As I feared this only happens with older
gnome-keyb- settings. I had some other gnome problems so I created a new user
and the problem is gone. Now if I log into my wife's account I not only get the
dialog with:
"Error activating XKB configuration.". But also (at the same time) the dialog
with: "The X system keyboard settings differ from your current GNOME keyboard
settings.  Which set would you like to use?" . So this problem might very well
be in another component.

If you still want it upstream let me know and I'll file there.
Comment 3 Hans de Goede 2006-06-01 04:01:38 EDT
I'm busy cleaning up some of my old bugs, closing.

AFAIK this is the us_intl has gone away problem already reported elsewhere, I
dunno the bug so I'm not closing it as a dup (which it probably should).


Note You need to log in before you can comment on or make changes to this bug.