Bug 184504 - Patches to build scipy
Patches to build scipy
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 07:10 EST by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 10:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
numpy-build_clib.patch (689 bytes, patch)
2006-03-09 07:10 EST, Neal Becker
no flags Details | Diff
scipy-d1mach.patch (1.17 KB, patch)
2006-03-09 07:10 EST, Neal Becker
no flags Details | Diff
scipy.spec (1.47 KB, text/plain)
2006-03-09 07:11 EST, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2006-03-09 07:10:00 EST
Description of problem: 
Please see attached patches  
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Neal Becker 2006-03-09 07:10:00 EST
Created attachment 125870 [details]
numpy-build_clib.patch
Comment 2 Neal Becker 2006-03-09 07:10:50 EST
Created attachment 125871 [details]
scipy-d1mach.patch
Comment 3 Neal Becker 2006-03-09 07:11:45 EST
Created attachment 125872 [details]
scipy.spec
Comment 4 Ignacio Vazquez-Abrams 2006-04-19 22:46:12 EDT
Are these still useful for the latest versions of numpy and scipy?
Comment 5 Neal Becker 2006-04-20 07:02:53 EDT
They are not just useful but required AFAIK.
Comment 6 Jonathan Underwood 2006-08-15 06:37:08 EDT
Would be really great to get these pushed asap for FC-5.
Comment 7 Jarod Wilson 2006-09-05 15:06:54 EDT
Looks like numpy-build_clib.patch isn't necessary for numpy 0.9.8, which I'm
working on packaging up right now. As for the other bits, they look like they're
scipy-specific, which I don't own, but presumably, once I push out 0.9.8, scipy
ought to finally be buildable...
Comment 8 Jarod Wilson 2006-09-06 10:42:41 EDT
0.9.8 should show up shortly.

http://buildsys.fedoraproject.org/logs/fedora-development-extras/16296-numpy-0.9.8-1.fc6/
Comment 9 Jonathan Underwood 2006-09-06 11:42:29 EDT
OK - hopefully Neal will get chance to look at that. I have emailed him
independently, as I would be interested in co-maintaining SciPY, but as yet
haven't had a reply. If he doesn't resurface, I'll perhaps pick up with the
SciPy review.
Comment 10 Neal Becker 2006-09-06 16:27:13 EDT
I'm still here.  Not sure what to do.  I'm becoming a bit concerned with 
numpy.  Every time there's a new upstream, I try it.  It never builds.  I 
report problems upstream.  I never (or almost never) get any reply.  I tried 
1.0b4 and 1.0b5.  Both fail with some mysterious message.  The build system is 
unfamiliar and I don't think I want to debug it.
Comment 11 Jarod Wilson 2006-09-06 17:14:55 EDT
If you would, please try with numpy 0.9.8 when it actually makes its way over to download mirrors. Things 
seem to be a bit sluggish with the FE build system right now... (That, or pull numpy 0.9.8 from FE cvs).
Comment 12 Neal Becker 2006-09-08 17:23:17 EDT
numpy-0.9.8-1 build OK on FC5 (x86_64)

scipy-0.4.8-4 build OK on top of this.  Quick test seems OK.

Note You need to log in before you can comment on or make changes to this bug.