Bug 184505 - Configuration files are incongruent.
Summary: Configuration files are incongruent.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tinyerp (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-09 12:14 UTC by Francesco Pelullo
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 3.2.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-18 14:42:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Francesco Pelullo 2006-03-09 12:14:18 UTC
Description of problem:
The configuration file
/etc/tinyerp-server.conf
contain variables that are incongruent with 
/usr/lib/python2.4/site-packages/tinyerp-server/tools/config.py
Those of that, it's difficult follow examples into online documentation, e.g.
loading a new language translation file into the server.

Version-Release number of selected component (if applicable):
3.2.1-1.fc4

How reproducible:
It's sufficient to load a new translation file into the server.

Steps to Reproduce:
1. # wget http://www.tinyerp.org/download/i18n/italian_it-2_1_1.csv
2. # service tinyerp-server stop
3. # tinyerp-server --i18n-import=italian_it-2_1_1.csv -l it
  
Actual results:
Language won't load into the server.
In /var/log/tinyerp/tinyerp-server.log:
...
Thu, 09 Mar 2006 12:15:17 INFO:objects:initialising distributed objects services
Thu, 09 Mar 2006 12:15:17 INFO:init:connecting to database
Thu, 09 Mar 2006 12:15:17 ERROR:init:could not connect to database 'terp'!

    Ident authentication failed for user "postgres"
...
This because IMHO the variables "db_name" and "db_user" into tinyerp-server.conf
are different by "db_name" and "db_user" in
/usr/lib/python2.4/site-packages/tinyerp-server/tools/config.py

Instead of .3 above, I've already tried all the following combinations:
# tinyerp-server --i18n-import=italian_it-2_1_1.csv -l it -d tinyerp
# tinyerp-server --i18n-import=italian_it-2_1_1.csv -l it -d tinyerp -r tinyerp

Expected results:
A new language is available.

Additional info:
Running
# service tinyerp-server stop
# tinyerp-server --i18n-import=italian_it-2_1_1.csv -l it
# service tinyerp-server start
don't works, because /var/spool/tinyerp/tinyerp-server.pid was not deleted when
the server crashes.
See also bug # 184502.

Comment 1 Dan Horák 2006-03-10 08:13:58 UTC
config file - I will create and package a new config file only with default
values. When the values will be changed it will be required to start the server
the from command line with "-c /etc/tinyerp-server.conf" appended.

Comment 2 Dan Horák 2006-03-10 09:04:27 UTC
The config is generated by running the current server (3.2.1), so it represents
the real state of the code and can differ from the documentation.


Note You need to log in before you can comment on or make changes to this bug.