Bug 184506 - libtool has a require for gcc version
libtool has a require for gcc version
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libtool (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2006-03-09 07:15 EST by Johnny Hughes
Modified: 2015-01-07 19:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-31 06:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johnny Hughes 2006-03-09 07:15:17 EST
Description of problem:
libtool has a requirement for gcc version.  The current version of libtool
provided with RHEL 4 requires gcc-3.4.3

The gcc shipped with RHEL is now gcc-3.4.5

libtool needs to be rebuilt with gcc-3.4.5 (and for every change of gcc) or the
change (from the changelog) for Fri Feb 25 2005 needs to be backed out of libtool.

How reproducible:
Comment 1 Karsten Hopp 2006-05-31 06:24:55 EDT
gcc-3.4.5 provides gcc-3.4.3, too:
$ rpm -qp --provides gcc-3.4.5-2.i386.rpm
gcc = 3.4.3-26
gcc = 3.4.5-2

And it provides all neccessary files:
$ rpm -qpl gcc-3.4.5-2.i386.rpm | grep .3.4.3
Comment 2 Alex Owen 2006-09-07 18:27:29 EDT
arguably the dependancy in libtool should be: gcc (>= 3.4.3)

Note You need to log in before you can comment on or make changes to this bug.