Bug 184521 - patch: Detect when bcm43xx has associated
patch: Detect when bcm43xx has associated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 11:26 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: kernel 2.6.16-1.2088_FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 13:36:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detect bcm43xx association (1.05 KB, patch)
2006-03-09 11:26 EST, Caolan McNamara
no flags Details | Diff
upstream ieee80211 softmac suggested fix (2.65 KB, patch)
2006-03-09 13:21 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Caolan McNamara 2006-03-09 11:26:08 EST
I guess the bcm43xx driver is doing the wrong thing, but the following patch
allows wpa_supplicant to detect that my bcm32xx has associated and authenticated
again my WEP access point. NetworkManager's dhclient then runs and everything
looks great, as opposed to the current "associated timeout" error.

Sadly a iwlist scan, and/or NetworkManagers equivalent scan hoses the
connection, so I only get a miniscule window before the connection dies. So this
is of limited utility I guess unless bcm43xx can keep it's connection alive
during scanning, but perhaps useful to identify what needs to be fixed in the
driver for association.
Comment 1 Caolan McNamara 2006-03-09 11:26:09 EST
Created attachment 125880 [details]
detect bcm43xx association
Comment 2 Dan Williams 2006-03-09 13:21:35 EST
Created attachment 125890 [details]
upstream ieee80211 softmac suggested fix

Suggested fix for upstream ieee80211 softmac project
Comment 3 Dan Williams 2006-03-09 13:27:39 EST
Patch sent to netdev and softmac-dev for comments.
Comment 4 Caolan McNamara 2006-03-09 13:53:15 EST
looks like the good stuff
Comment 5 Caolan McNamara 2006-03-27 13:36:34 EST
All seems to work fine now with 2.6.16-1.2088_FC6 (horay!)

Note You need to log in before you can comment on or make changes to this bug.