Bug 184522 - Thunderbird freezes for several seconds periodically
Thunderbird freezes for several seconds periodically
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 11:51 EST by Orion Poplawski
Modified: 2007-12-11 15:06 EST (History)
1 user (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 15:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-03-09 11:51:28 EST
Description of problem:
A couple times a day, thunderbird will become unresponsive for about 5-10
seconds.  It then continues along fine.  I use IMAP to connect to our mail
server.  I'll try to get a trace during a freeze.

Version-Release number of selected component (if applicable):
thunderbird-1.5-3
Comment 1 Richard Dawe 2006-12-16 16:07:22 EST
What are you doing when it freezes for you?

I also some freezes, but I think they may be a separate problem. Here's what
happens for me. I forward an e-mail. It takes some time for the message window
to appear. It may be related to mails containing HTML/XML, although I'm not sure
of that. Anyhow, I enter a recipient, then it hangs for several tens of seconds
with 100% CPU (on an Athlon 850MHz, 640MB RAM). I enter another recipient, it
hangs for tens of seconds.

Do you see behaviour like that?

For the problem I've seen, I've tried stracing thunderbird and I see a lot of
repetitive CORBA requests/response on a Unix domain socket with "linc" in the
name. It seems like thunderbird is doing the same request a number of times,
before it finally moves onto something tens of seconds later. I guess it might
be querying something for readiness. I'll try to debug it some more.
Comment 2 Richard Dawe 2006-12-30 14:41:34 EST
The issue I mention above is something separate (filed as in Mozilla Bugzilla at
<https://bugzilla.mozilla.org/show_bug.cgi?id=365419>). Sorry for the noise.
Comment 3 Orion Poplawski 2007-03-27 16:59:49 EDT
I'm still seeing pretty frequent pauses.  Possibly mail folder compacting?  Any
good ways to trace to see what's going on?

thunderbird-1.5.0.10-1.fc6
Comment 4 Richard Dawe 2007-03-27 17:14:52 EDT
(In reply to comment #3)
> I'm still seeing pretty frequent pauses.  Possibly mail folder compacting?  Any
> good ways to trace to see what's going on?
> 
> thunderbird-1.5.0.10-1.fc6

I'm using that version as well. I believe Thunderbird will prompt you, before
compacting folders. At least, it does the way mine is configured. If you go into
Edit menu -> Preferences, then select the Advanced section, then select Offline
& Disk Space, do you have "Compact folders when it will save over [number]" enabled?
Comment 5 Orion Poplawski 2007-03-28 12:45:25 EDT
I do have compact enabled.  I do get prompted when I shift to a news server off
of my IMAP account, and that seems to be fast to perhaps that's not it. 
thunderbird cpu utilization jumps to around 70-80 during the pause, so it's
definitely doing something.
Comment 6 Matěj Cepl 2007-05-17 11:35:41 EDT
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)?
Comment 7 Orion Poplawski 2007-05-17 11:41:46 EDT
Not running FC6 on my machine at the moment, I'm running Rawhide.  Not sure it's
still pausing like it did before.  What I do notice the most now is that when I
send an email the whole system often becomes unresponsive for a few seconds
(can't raise other windows though the cursor moves).

Comment 8 Orion Poplawski 2007-05-17 12:10:12 EDT
During the hang the compose status line is "looking up mail.cora.nwra.com"
Comment 9 Orion Poplawski 2007-05-17 13:29:22 EDT
Actually, it lasts until the compose window closes.
Comment 10 Richard Dawe 2007-05-19 04:57:49 EDT
(In reply to comment #7)
> Not running FC6 on my machine at the moment, I'm running Rawhide.  Not sure it's
> still pausing like it did before.  What I do notice the most now is that when I
> send an email the whole system often becomes unresponsive for a few seconds
> (can't raise other windows though the cursor moves).

I see this too with thunderbird-1.5.0.10-1.fc6 on i386. Composing a message,
then clicking send causes the CPU on my machine to hit 100% for tens of seconds.
When it hangs, it can time out the send operation. The status shown is that it
is trying to connect to the SMTP server -- which is odd, because the SMTP server
is up and running fine.

Sometimes (~25%-50% of the time?) there is no hang, and sending works fine.

I've got spellchecking disabled.

I'm using postfix-2.3.3-2 as the local MTA, with spamassassin-3.1.8-2.fc6 for
spam filtering. spamassassin is invoked via procmail-3.22-17.1. My
/etc/procmailrc is:

  DROPPRIVS=yes
  
  # Log
  LOGFILE=${HOME}/procmail.log
  LOGABSTRACT=yes
  
  :0fw
  | /usr/bin/spamc

Orion Poplawski, what SMTP server are you using?
Comment 11 Orion Poplawski 2007-06-01 19:01:17 EDT
I'm using a CentOS 5 sendmail SMTP server.  No problems with anything else. 
I've got some big IMAP folders, but again this is definitely a new problem.

Interestingly, I've tried to use strace to see where the hangup is, but the
problem goes away with strace running.  Any other ways to figure out what the
heck it's doing?
Comment 12 Richard Dawe 2007-06-02 04:08:50 EDT
I wrote up my experiences debugging another Thunderbird issue here:

http://www.advogato.org/person/richdawe/diary.html?start=116
Comment 13 Matěj Cepl 2007-12-10 04:24:25 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 14 Orion Poplawski 2007-12-10 14:02:45 EST
This is a hard one to pin down, but there definitely are times with thunderbird
becomes unresponsive for no apparent reason on F8.
Comment 15 Matěj Cepl 2007-12-10 17:55:46 EST
Orion, I am sorry, but you know the rules of the game well enough -- unless you
are able to explain to us how to reproduce this bug, we cannot do much. Is there
anything particular about your configuration?

One thing which comes to my mind -- just before posting the message is saved to
the Sent folder. Do you have it on IMAP or local one? I believe that from nature
of remote Sent folder it could be possible that some small delay happens. Why
there is 100% CPU, I have no clue.
Comment 16 Richard Dawe 2007-12-11 13:54:22 EST
FWIW my Thunderbird issues have disappeared. I haven't seen any hangs / 100% CPU
usage since upgrading to FC8.

I have spell check before sending disabled, but spell check as I type enabled.
Comment 17 Matěj Cepl 2007-12-11 15:06:57 EST
cool. closing per reporter's request

Note You need to log in before you can comment on or make changes to this bug.