Bug 184541 - Some Acer Aspire 3002CLi key strokes don't seem to be noticed by X
Some Acer Aspire 3002CLi key strokes don't seem to be noticed by X
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Desktop
Depends On:
Blocks: 183415
  Show dependency treegraph
 
Reported: 2006-03-09 13:55 EST by Suzanne Hillman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 13:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6250 None None None Never

  None (edit)
Description Suzanne Hillman 2006-03-09 13:55:20 EST
Description of problem:
Some Acer Aspire 3002CLi key strokes don't seem to be noticed by X, presumably
because they are specific to this laptop.

I tested using xev to see if they were just not being understood, or if they
really were totally not being caught. The latter appears to be the case.

The keys are:

Up at the top near the caps keys indicators, web and email buttons (which do
work), and power button, a user-programmable one ('p'), and one which is
intended to work with Acer eManager (presumably a Windows app) but which is also
user-programmable (cursive 'e').

Near the arrow keys, the dollar sign (not sure why they thought we needed
another way to make a dollar sign, but whatever) and the euro symbol.

The <Fn> <F1>, <Fn> <F2>, and <Fn> <F3> all seem to not be noticed. <Fn> for
F4-F7 are also not seen, according to xev, but they appear to all go directly to
hardware so it likely doesn't matter. <Fn> <F8> seems to work fine, if one
associates it using the keyboard shortcuts utility.

This may be better labeled as an enhancement request; not sure.

Version-Release number of selected component (if applicable):
(Not completely sure which xorg.x11-foo version you need; giving the server, for
now.)
xorg-x11-server-Xorg-1.0.1-8

How reproducible:
Always

Steps to Reproduce:
1. Install yesterday's rawhide onto an Acer Aspire 3002CLi
2. Log into X.
3. Start xev, and see if these keys are noticed.
  
Actual results:
Not noticed by xev (I actually realized this when they were not showing up when
trying to associate via keyboard shortcuts)

Expected results:
Should be recognized by X.

Additional info:
Comment 1 Suzanne Hillman 2006-03-09 14:03:28 EST
Oops, sorry. It does appear to hear the <fn> f1-3 keys, even though they don't
show up as seen in xev. I checked using the keyboard shortcuts tool, and they're
seen.

The other four, however, are not seen when trying to set keyboard shortcuts.

Wondering, though, if there's some other tool I should be using to see if keys
are noticed by X, if xev doesn't necessarily notice them?
Comment 2 Suzanne Hillman 2006-03-09 14:07:11 EST
Finally, and I'm not entirely sure if this is something that's reasonable to
expect to work, there is a <alt gr> key (in the place of the right <alt> key),
which is apparently heard as <alt_R> by the keyboard shortcuts tool, and which
is supposed to be able to combine with another key (5) to create the Euro
symbol. I think that's the only key which uses the alt gr key, and if we get the
key which is near the arrow keys and _only_ handles that working, it may not matter.
Comment 3 Mike A. Harris 2006-03-10 19:43:13 EST
Please file a bug report in the X.Org bugzilla located at
http://bugs.freedesktop.org in the "xkeyboard-config" component for this
issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 4 Suzanne Hillman 2006-03-13 11:01:10 EST
https://bugs.freedesktop.org/show_bug.cgi?id=6250
Comment 5 Suzanne Hillman 2006-03-13 15:32:10 EST
As far as comment #2, it looks like it is something that can be done using
configuration of the keyboard layout, since the alt gr key is seen, but it's
_very_ manual. It's some combination of defining which key should be used to be
able to create the Euro symbol, and defining which key to use in order to
trigger it. It relates not at all to the fact that it's actually labeled as such
on the keyboard. So... it _works_, with much configuration, but it'd seem to be
the kind of thing that we want to happen automatically, if possible.
Comment 7 Mike A. Harris 2006-06-14 13:06:21 EDT
Tracking in upstream bugzilla now.

Note You need to log in before you can comment on or make changes to this bug.