Bug 184551 - Dell GX620 using vesa, not i810 driver
Dell GX620 using vesa, not i810 driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hwdata (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 15:01 EST by Rex Dieter
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 11:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-03-09 15:01:23 EST
Despite having claimed to have been fixed in bug #163602, we're seeing the same
problem on a batch of new DELL GX620's purchased last week (using RHEL4 U2). 
Kickstart install autodetects to use vesa driver.  Manually using i810 driver fails.

$ lspci -v
...
00:02.0 VGA compatible controller: Intel Corporation 945G Integrated Graphics
Controller (rev 02) (prog-if 00 [VGA])
        Subsystem: Dell: Unknown device 01ad
        Flags: fast devsel, IRQ 11
        Memory at feb00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at e898 [size=8]
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Memory at feac0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2


New chipset?
Comment 1 Rex Dieter 2006-03-09 15:10:18 EST
OK, I lied.  Testing again (without typos this time) by manually using the i810
driver *does* work.

Now the problem is that this chipset isn't pnp'ing as i810.
Comment 2 Rex Dieter 2006-03-09 15:27:04 EST
adding to /usr/share/hwdata/pcitable:
0x8086  0x2772  "Card:Intel 945"

and
adding to /usr/share/hwdata/Cards:
NAME Intel 945
CHIPSET Intel 945
DRIVER i810
NOCLOCKPROBE

made lspci not say "unknown device" and made system-config-display --reconfig
properly detect the chipset.
Comment 3 Rex Dieter 2006-03-09 15:33:08 EST
Re-assigned to hwdata...
Comment 4 Rex Dieter 2006-03-09 15:45:06 EST
Apparently a dup of bug #170517, but I can't confirm that (not authorized to
view it).
Comment 5 Phil Knirsch 2006-07-11 10:05:30 EDT
Should be fixed in next hwdata package for RHEL4U4 which includes an update of
the pci.ids and pcitable that has the missing entries.

Cards already contains an entry for the Intel 945 chips:

NAME Intel 945
DRIVER i810
NOCLOCKPROBE

So should work with U4 then.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.