Bug 184589 - notify-send --help shows multiple '-t' options
notify-send --help shows multiple '-t' options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 20:17 EST by James Laska
Modified: 2013-09-02 02:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 01:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2006-03-09 20:17:23 EST
# RPM libnotify-0.3.0-5.i386

notify-send shows multiple options that respond to the '=t' switch.  As the text
below indicates, both --expire-time (-t) and --type (-t) use the same short option.

$ notify-send --help
Usage: notify-send [OPTIONS]* <summary> [body]
  -u, --urgency=STRING           Specifies the urgency level (low, normal,
                                 critical).
  -t, --expire-time=INT          Specifies the timeout in seconds at which to
                                 expire the notification.
  -i, --icon=ICON1,ICON2,...     Specifies an icon filename or stock icon to
                                 display.
  -t, --type=ICON1,ICON2,...     Specifies the notification type.

Help options:
  -?, --help                     Show this help message
  --usage                        Display brief usage message
Comment 1 Matthias Clasen 2006-03-11 10:55:07 EST
Probably best to file upstream. John, is there an upstream bug tracker for
libnotify ?
Comment 2 Matthias Clasen 2007-06-17 01:24:25 EDT
This has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.