Bug 18480 - kernel/kswapd paging hang
kernel/kswapd paging hang
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 19:17 EDT by Bill Chatfield
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 19:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Chatfield 2000-10-05 19:17:37 EDT
My system locked up completely while it was doing nothing but running the
screen saver.  This is what was in /var/log/messages.

Oct  5 14:05:00 jhad kernel: Unable to handle kernel paging request at
virtual address 00002000
Oct  5 14:05:00 jhad kernel: current->tss.cr3 = 00101000, %cr3 = 00101000
Oct  5 14:05:00 jhad kernel: *pde = 00000000
Oct  5 14:05:00 jhad kernel: Oops: 0002
Oct  5 14:05:00 jhad kernel: CPU:    0
Oct  5 14:05:01 jhad kernel: EIP:    0010:[remove_inode_page+86/112]
Oct  5 14:05:01 jhad kernel: EFLAGS: 00210206
Oct  5 14:05:01 jhad kernel: eax: c02b8860   ebx: c02b61c8   ecx:
c02b61c8   edx: 00002000
Oct  5 14:05:01 jhad kernel: esi: 000001fe   edi: 00000030   ebp:
00000e00   esp: c7e77fbc
Oct  5 14:05:01 jhad kernel: ds: 0018   es: 0018   ss: 0018
Oct  5 14:05:01 jhad kernel: Process kswapd (pid: 5, process nr: 5,
stackpage=c7e77000)
Oct  5 14:05:01 jhad kernel: Stack: 0000000f 00000006 c01222ca 00000006
00000030 c7e76000 c01dca0e c7e761c1
Oct  5 14:05:01 jhad kernel:        c0122383 00000030 00000f00 c7ffbfc0
c0106000 c0108acb 00000000 00000f00
Oct  5 14:05:01 jhad kernel:        c0235fd8
Oct  5 14:05:01 jhad kernel: Call Trace: [do_try_to_free_pages+38/120]
[tvecs+7598/14080] [kswapd+103/156] [get_options+0/116]
[kernel_thread+35/48]
Oct  5 14:05:01 jhad kernel: Code: 89 02 c7 01 00 00 00 00 c7 41 04 00 00
00 00 31 d2 89 c8 e8

This is the standard single processor kernel and kswapd that comes with
RHL7.

If there is any more information that I can collect to diagnose this
problem, please let me know and I'll try to get it.
Comment 1 Bill Chatfield 2000-11-05 00:48:13 EST
It was caused by a hardware problem.

Note You need to log in before you can comment on or make changes to this bug.